fedup failure from F19->F20

Adam Williamson awilliam at redhat.com
Mon Apr 28 22:49:45 UTC 2014


On Mon, 2014-04-28 at 15:42 -0700, Rick Stevens wrote:

> > Thanks again for the help. I may be back for more. I hope not, but the
> > way my luck goes...........
> 
> Well, as suspected, it crapped out again. I get this at the end of
> the fedup command:
> 
> 	Traceback (most recent call last):
> 	  File "/bin/fedup", line 239, in <module>
> 	    main(args)
> 	  File "/bin/fedup", line 219, in main
> 	    for line in s.format_details():
> 	AttributeError: 'ProblemSummary' object has no attribute 'format_details'

That looks like some issue with printing a nice summary of what went
wrong, but not actually anything to do with what went wrong.

> Prior to that, I get a ridiculous amount of package conflict errors,
> most invoving perl:
> 
> 	perl-Params-Classify-0.013-7.fc19.x86_64 requires 
> perl-4:5.16.3-266.fc19.x86_64
> 
> So, I guess I'm in deep trouble here. I suspect this is going to require
> a full install of F20 rather than a fedup. Dang!

Don't give up yet. This is the 'real problem', and just because there
seem to be a lot of errors doesn't mean it's intractable, as they all
seem to be related. If you could pastebin the entire output, I might be
able to help.
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net
http://www.happyassassin.net



More information about the test mailing list