fedup failure from F19->F20

Adam Williamson awilliam at redhat.com
Tue Apr 29 00:58:58 UTC 2014


On Mon, 2014-04-28 at 16:41 -0700, Rick Stevens wrote:
> On 04/28/2014 04:15 PM, Samuel Sieb issued this missive:
> > On 04/28/2014 03:42 PM, Rick Stevens wrote:
> >> Prior to that, I get a ridiculous amount of package conflict errors,
> >> most invoving perl:
> >>
> >>      perl-Params-Classify-0.013-7.fc19.x86_64 requires
> >> perl-4:5.16.3-266.fc19.x86_64
> >>
> > That looks more like part of a broken dependency chain.  For example
> > maybe you installed a package that requires some specific version of a
> > perl package, but doesn't have an update.
> 
> Looking at the litany of errors reported in fedup.log, virtually every
> Perl module I have seems to whine and they all say they want that
> perl-4:5.16.3-266.fc19.x86_64 RPM. That is the perl version installed 
> and it's the latest version of perl available for F19. I'm rather stumped.

The reason I want to see the log is there is likely an underlying cause;
to put it very broadly and squishily, your package set is probably
causing yum to get confused trying to obey two imperatives, something
along the lines of 'we want to update perl and all these perl
dependencies, but one obstinate package doesn't have a newer version
which requires the newer version of perl and is gumming up the whole
works'. You might *expect* that to produce an immediately obvious single
error message pointing to the one culprit package, but in my experience
that isn't always the case. But it's hard to say for sure without seeing
the full log.
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net
http://www.happyassassin.net



More information about the test mailing list