Fedora-Minimal-armhfp-21-20140730-sda.raw.xz on Cubieboard 2 - problems

Robert Moskowitz rgm at htt-consult.com
Thu Jul 31 13:35:43 UTC 2014

It took me a bit to work out issues with the serial console to get back 
into testing.  Those issues are for a separate list...

I can get Minimal to go through the install process and set timezone, 
root password, and userid.  When I go to log in I get:

Fedora release 21 (Twenty One)
Kernel 3.16.0-0.rc7.git1.1.fc21.armv7hl on an armv7l (ttyS0)

localhost login: root
[   64.141895] cfg80211: Calling CRDA to update world regulatory domain
[   66.257749] eth0: device MAC address c2:f5:e1:51:08:dd
[   66.450111]  No MAC Management Counters available
[   66.712730]  No MAC Management Counters available
[   66.718353] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

[   68.632241] stmmaceth 1c50000.ethernet eth0: Link is Up - 
100Mbps/Full - flow control off
[   68.649252] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Last login: Wed Dec 31 19:04:26 on ttyS0
[root at localhost ~]# ifconfig
-bash: ifconfig: command not found
[root at localhost ~]# echo $PATH
[root at localhost ~]#

No commands work.  I know the IP address this device gets assigned so I 
tried pinging and ssh:

]# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=47 time=78.8 ms
64 bytes from icmp_seq=2 ttl=47 time=77.1 ms
--- ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 77.167/78.009/78.852/0.887 ms
# ssh -l root
ssh: connect to host port 22: Connection refused

You can probably ping it yourself, but port 22 is blocked at the 
firewall router.

I powered off and rebooted, and still the same behaviour.  I did a 
screen capture of the install, so can provide that if it would help 
(54K).  Note I have had this problem since I started on Minimal with the 
20140724 build, but have not been able to stablily test it.  I believe 
my setup now provides a reliable test of the build on a Cubieboard 2.

Further note that I have a F19 and F20 remix working on this system on 
other SD cards.  I can boot any of the versions just by switching which 
card is in it.

Thank you and I await advise on what to provide next (or a build that 
works for me).

More information about the test mailing list