Fedora-Minimal-armhfp-21-20140730-sda.raw.xz on Cubieboard 2 - problems

Peter Robinson pbrobinson at gmail.com
Thu Jul 31 13:55:45 UTC 2014

On Thu, Jul 31, 2014 at 2:35 PM, Robert Moskowitz <rgm at htt-consult.com> wrote:
> It took me a bit to work out issues with the serial console to get back into
> testing.  Those issues are for a separate list...
> I can get Minimal to go through the install process and set timezone, root
> password, and userid.  When I go to log in I get:
> Fedora release 21 (Twenty One)
> Kernel 3.16.0-0.rc7.git1.1.fc21.armv7hl on an armv7l (ttyS0)
> localhost login: root
> Password:
> [   64.141895] cfg80211: Calling CRDA to update world regulatory domain
> [   66.257749] eth0: device MAC address c2:f5:e1:51:08:dd
> [   66.450111]  No MAC Management Counters available
> [   66.712730]  No MAC Management Counters available
> [   66.718353] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
> [   68.632241] stmmaceth 1c50000.ethernet eth0: Link is Up - 100Mbps/Full -
> flow control off
> [   68.649252] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
> Last login: Wed Dec 31 19:04:26 on ttyS0
> [root at localhost ~]# ifconfig
> -bash: ifconfig: command not found
> [root at localhost ~]# echo $PATH
> /usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
> [root at localhost ~]#
> No commands work.  I know the IP address this device gets assigned so I
> tried pinging and ssh:

the ip command as replaced pretty much all stuff (actually around 10
years ago!) but once you get use it it is much nicer. There's a quick
start here http://andys.org.uk/bits/2010/02/24/iproute2-life-after-ifconfig/
or you can do "yum install net-tools" and get the old ones back.

> You can probably ping it yourself, but port 22 is blocked at the firewall
> router.

firewall-cmd --help

> I powered off and rebooted, and still the same behaviour.  I did a screen
> capture of the install, so can provide that if it would help (54K).  Note I
> have had this problem since I started on Minimal with the 20140724 build,
> but have not been able to stablily test it.  I believe my setup now provides
> a reliable test of the build on a Cubieboard 2.

It's expected behaviour so I'm not sure why you'd expect it to change,
if you don't need a firewall you can just "yum remove firewalld"

> Thank you and I await advise on what to provide next (or a build that works
> for me).

So I'm not sure what isn't working. The two issues you had above with
network config and firewall are by design and there's a lot of good
docs on the Fedora wiki and elsewhere that cover them and I've given
you alternatives to the default. Is there anything else you need?


More information about the test mailing list