<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    Three use cases in which in my opinion the behavior is clearly
    incorrect:<br>
    <br>
    Case 1:<br>
    <ol>
      <li>Put DVD in drive while logged in. DVD is mounted.</li>
      <li>Reboot computer and log back in. DVD is not mounted. It should
        be.</li>
    </ol>
    Case 2:<br>
    <ol>
      <li>Put DVD in drive before logging in. DVD is not mounted.</li>
      <li>Log in. DVD is not mounted. It should be.</li>
    </ol>
    Case 3:<br>
    <ol>
      <li>Put DVD in drive while logged in. DVD is mounted.</li>
      <li>Log out. DVD stays mounted under /run/media/$USER. It should
        have been unmounted when you logged out.</li>
      <li>Log back in as another user. DVD is still mounted under
        /run/media/<i>previous-$USER</i>. It should have been remounted
        under your $USER.</li>
    </ol>
    jik<br>
    <br>
    On 04/18/2012 02:40 PM, Bill Nottingham wrote:
    <blockquote
      cite="mid:20120418184007.GA1551@nostromo.devel.redhat.com"
      type="cite">
      <pre wrap="">Adam Williamson (<a class="moz-txt-link-abbreviated" href="mailto:awilliam@redhat.com">awilliam@redhat.com</a>) said: 
</pre>
      <blockquote type="cite">
        <pre wrap="">On Wed, 2012-04-18 at 13:10 -0400, Jonathan Kamens wrote:

</pre>
        <blockquote type="cite">
          <pre wrap="">Yes, I'm aware of that, but that's not what I want.

If it is the position of the Fedora developers that /run/media/$USER
is the right place for stuff to be mounted, and I don't have a
particular problem with that decision, then I want that behavior,
i.e., the behavior that the developers think is correct, with the F16
behavior of the device being mounted automatically when I log in.

Why shouldn't it act that way?
</pre>
        </blockquote>
        <pre wrap="">
Oh, I see. I don't know about that. I don't know if there's a way to
make GNOME mount devices on login rather than on access. I think that's
a GNOME policy question rather than a udisks one. It may be worth asking
on the desktop list. Matthias, are you reading this?
</pre>
      </blockquote>
      <pre wrap="">
So, I'm a bit confused. I tried to reproduce this with a USB stick today.

If I plug it in while I'm logged in, it shows up. I log out and log back in,
and it still shows up.

If I reboot, plug it in during GDM, and then log in... it shows up. Under
what circumstance does it not show up for you?

Bill
</pre>
    </blockquote>
  </body>
</html>