500 error when submitting paprefs

Dimitris Glezos dimitris at glezos.com
Wed Oct 8 14:56:44 UTC 2008

2008/10/8 Dimitris Glezos <dimitris at glezos.com>:
> 2008/10/8 Miloš Komarčević <kmilos at gmail.com>:
>> On Tue, Oct 7, 2008 at 3:36 PM, Göran Uddeborg <goeran at uddeborg.se> wrote:
>>> Milo? Komar?evi? writes:
>>>> Problems with non-ASCII user names again?
>>> I just realised you wrote "user name" here.  The bugzillas seemed to
>>> refer to content of the po files.  But my full name does contain
>>> non-ASCII letters.
>>> So I tried to change my settings in the wiki modifying the full name
>>> to contain only ASCII.  But I still get the error.  It wasn't that
>>> easy to work around the problem; I still can't submit any Swedish
>>> translations.
>> Changing your name in the wiki doesn't do anything, you have to change
>> it in FAS.
>> Just tried, and it worked for me, managed to submit to paprefs.
> Today Toshio and I worked for quite a while debugging the problem,
> which ended up being a tricky one. With a recent upstream package
> change, one of the DB queries seemed to lose its encoding somewhere
> between the Tx backend, the TG ORM layer (sqlobject), mysql and the DB
> itself. The problem was found by Toshio after an hour of debugging the
> internals of the libraries, and our mysql bindings need updating.
> Since this is a RHEL box, we can't 'just' push an update, so we'll
> investigate how to move Tx to a Fedora box and probably update it to
> the newer version.
> The issue affects folks with Unicode characters in their names on the
> Fedora Account System. Until we have a fix published (might take some
> days), people from this group who need to submit translations before
> the fix, will need login to FAS (admin.fpo/accounts) and change their
> name to only contain ascii letters.

>From what I can tell, we've fixed the problem and tested the fix successfully.

There is little chance of a regression in the future, until upstream
accepts our patch. Should be OK though.

Please test, and drop by IRC if something is not working for you. Ping
me and Toshio (abadger1999) on #fedora-l10n and #fedora-admin.


Dimitris Glezos
Jabber ID: glezos at jabber.org, GPG: 0xA5A04C3B

"He who gives up functionality for ease of use
loses both and deserves neither." (Anonymous)

More information about the trans mailing list