Unable to rebuild mysql 4.0.16 source rpm

Kaj J. Niemi mail.sw.rh.rhl at spam.fi.basen.net
Fri Nov 21 15:40:49 UTC 2003

> perl(the) is needed by MySQL-client-4.0.16-0

Add the following to your mysql.spec:

Source999: filter-requires-mysql.sh

%define __perl_requires %{SOURCE999}

and create filter-requires-mysql.sh in SOURCES (or SOURCES/mysql or whatever
your buildstructure is) with the following content:

/usr/lib/rpm/perl.req $* | grep -v "perl(th"

What you're doing is really at package building time excluding the
dependency to perl(the) which is bogus. :)

// kaj

More information about the users mailing list