another yum/python problem

Mark McGlone dmcglone at san.rr.com
Sun Feb 15 16:08:27 UTC 2004


I've noticed a few other people having a problem like this but mine
appears to be a little different.

I get the following error when trying to run yum

     Traceback (most recent call last):
       File "/usr/bin/yum", line 22, in ?
	 import yummain
       File "/usr/share/yum/yummain.py", line 30, in ?
	 import yumcomps
       File "/usr/share/yum/yumcomps.py", line 4, in ?
	 import comps
       File "/usr/share/yum/comps.py", line 5, in ?
	 import libxml2
       File "/usr/lib/python2.2/site-packages/libxml2.py", line 1, in ?
     ImportError: No module named libxml2mod

This happend right after installing kdebase (3.2.0) from the development
archive.  As seen below.


     02/15/04 09:34:15 Dep Installed: libxml2 2.6.6-1.i386
     02/15/04 09:34:15 Dep Installed: libxml2-python 2.6.6-1.i386
     02/15/04 09:34:15 Dep Installed: qt-devel 1:3.3.0-0.2.i386
     02/15/04 09:34:15 Dep Installed: qt 1:3.3.0-0.2.i386
     02/15/04 09:34:15 Dep Installed: arts 8:1.2.0-0.3.i386
     02/15/04 09:34:15 Dep Installed: redhat-artwork 0.91-2.i386
     02/15/04 09:34:15 Dep Installed: kdelibs 6:3.2.0-0.4.i386
     02/15/04 09:34:15 Dep Installed: libxml2-devel 2.6.6-1.i386
     02/15/04 09:34:15 Updated: kdebase 6:3.2.0-0.4.i386

Unlike other people I do not have python 2.3 installed. The version I have is
python 2.2.3. Can anyone suggest anything?

thanks in advance,

Mark McGlone





More information about the users mailing list