Yum dependencies [still]

Steffen Kluge kluge at fujitsu.com.au
Thu Dec 22 01:06:14 UTC 2005

On Tue, 2005-12-20 at 22:44 -0500, M. Lewis wrote:
> Error: Missing Dependency: nvidia-glx = 0:1.0.7676 is needed by package 
> kernel-module-nvidia-2.6.13-1.1532_FC4

Your problem is that not only the kernel version version went up, but
also the NVidia driver version. Whenever NVidia issues a new driver
version Livna will build nvidia-glx and kernel module packages for it,
but only for the current kernel and up.

In this case, you tried to install kernel-module-nvidia for the latest
kernel, which is kernel-module-nvidia-2.6.14-1.1653*-1.0.8174-*. It
requires a matching version of nvidia-glx (1.0.8174), hence nvidia-glx
needs to upgraded, too. However, the old nvidia-glx version (1.0.7676)
is required by your older kernel-module-nvidia versions, which yum will
not remove automatically, you'll have to do that manually.

The root cause of this issue is that kernel and kernel module packages
can exist in multiple versions on the same system, since they live in
versioned directories and have no conflicting files. Other packages
(like nvidia-glx) cannot have multiple versions installed at the same
time. If you want to use the latest kernel with NVidia's proprietary
driver you have to wave your old NVidia kernel modules good-bye. That
means no proprietary NVidia driver support when you boot older kernels.

Nobody's fault, really. The only way out would be convincing someone to
build the NVidia modules against x number of older kernels, as well.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.fedoraproject.org/pipermail/users/attachments/20051222/67d037a2/attachment-0002.bin 

More information about the users mailing list