Need help wuth yum new fc4 installation -

Paul Howarth paul at city-fan.org
Fri Jul 8 10:14:52 UTC 2005


Bob Goodwin wrote:
> I am really stuck without a working yum in FC4 installed yesterday.
> I've modified/copied various yum.conf files without success.

FC3 and FC4 use repository configurations in /etc/yum.repos.d in 
preference to /etc/yum.conf

=> Presently getting error:
> 
> yum install whichcd
> Repository updates-testing already added, not adding again
> Repository base already added, not adding again

Remove the entries for repos updates-testing and base from your yum.conf 
(which clash with other entries in /etc/yum.repos.d) to clear these 
warnings.

> Setting up Install Process
> Setting up repositories
> at-stable                 100% |=========================|  951 B
> 00:00
> updates-released          100% |=========================|  951 B
> 00:00
> http://rpm.livna.org/fedora/4/i386/yum/stable/repodata/repomd.xml:
> [Errno 4] IOError: HTTP Error 404: Date: Fri, 08 Jul 2005 09:49:46 GMT
> Server: Apache/2.0.51 (Fedora)
> Content-Length: 323
> Connection: close
> Content-Type: text/html; charset=iso-8859-1
> Trying other mirror.
> Cannot open/read repomd.xml file for repository: livna-stable
> failure: repodata/repomd.xml from livna-stable: [Errno 256] No more
> mirrors to try.
> 
> Perhaps someone can point me in the right direction or provide a working
> configuration file.

Your livna repo definition is broken. Remove it from your /etc/yum.conf 
and then do:

# rpm -Uvh 
http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.2.4.noarch.rpm

(that's all one line).

Then try your yum command again. You'll probably want to do a "yum 
update" too.

Paul.




More information about the users mailing list