Problem with "yum update" after upgrading to FC-4

Timothy Murphy tim at birdsnest.maths.tcd.ie
Sun Jun 19 23:53:24 UTC 2005


I have rather similar dependency errors after "yum update"
on two machines - one with the i386 distribution and the other with x86_64 -
in each case involving libssl and libcrypto, 
eg with i386 (among many similar error messages) I get
=================================================
Error: Missing Dependency: libcrypto.so.5 is needed by package mysql-server
Error: Missing Dependency: libcrypto.so.5 is needed by package kdenetwork
Error: Missing Dependency: libssl.so.5 is needed by package samba
Error: Missing Dependency: libssl.so.5 is needed by package kdesdk
=================================================
while with x86_64 I just get
=================================================
Error: Missing Dependency: libcrypto.so.4()(64bit) is needed by package
spamassassin
Error: Missing Dependency: libssl.so.4()(64bit) is needed by package
spamassassin
=================================================

I notice that under FC-3
=================================================
/lib/libssl.so.4 -> libssl.so.0.9.7a
=================================================
while there is no such link after the upgrade.

I'm wondering if this will cure itself after a time,
or if there is something I need to do about it, and if so what?

Any suggestions or advice gratefully received.




-- 
Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland




More information about the users mailing list