Missing dependency when upgrading from FC3 to FC4

Edson Eustachio eeustachio at terra.com.br
Sat Jun 25 23:57:19 UTC 2005


Hello all,

I'm having the problem below when I try to upgrade my system from FC3 
for FC4. I've followed this steps 
(http://www.brandonhutchinson.com/Upgrading_Red_Hat_Linux_with_yum.html) 
but it fails to resolve the dependencies.
1) # rpm -Uvh 
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/fedora-release-4-2.noarch.rpm
Ok.
2) Disable third-party yum repositories,
OK.
[root at desktop yum.repos.d]# grep "enable" *
atrpms.repo:enabled=0
dag.repo:enabled=0
dries.repo:enabled=0
fedora-devel.repo:enabled=0
fedora-extras-devel.repo:enabled=0
fedora-extras.repo:enabled=0
fedora.repo:enabled=1
fedora.repo.rpmnew:enabled=0
fedora-updates.repo:enabled=0
fedora-updates.repo.rpmnew:enabled=0
fedora-updates-testing.repo:enabled=0
fedora-updates-testing.repo.rpmnew:enabled=0
freshrpms.repo:enabled=0
li.repo:enabled=0
newrpms.repo:enabled=0

3. When upgrading to Fedora Core 4, the kernel must be upgraded before 
the rest of the packages.
# yum -y update kernel
OK

4. Disable SELinux
[root at desktop sysconfig]# grep "SELINUX" selinux
# SELINUX= can take one of these three values:
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
SELINUXTYPE=targeted

5. Remove the Fedora Core 3 kernel(s) to prevent the aforementioned 
kernel-utils package dependency error.
# yum remove kernel-2.6.11\*FC3\*
OK

6. Continue the upgrade to Fedora Core 4.

[root at desktop /]# yum -y upgrade
...
...
...
--> Populating transaction set with selected packages. Please wait.
---> Package xml-common.noarch 0:0.6.3-17 set to be updated
---> Package openjade.i386 0:1.3.2-16 set to be updated
---> Package gnome-vfs2-smb.i386 0:2.10.0-5 set to be updated
---> Package sgml-common.noarch 0:0.6.3-17 set to be updated
---> Package gnome-icon-theme.noarch 0:2.10.1-4 set to be updated
--> Running transaction check
--> Processing Dependency: python = 2.3.4 for package: pythonabi
--> Processing Dependency: libraw1394.so.5 for package: ffmpeg
--> Processing Dependency: libraw1394.so.5 for package: libdc1394
--> Finished Dependency Resolution
Error: Missing Dependency: python = 2.3.4 is needed by package pythonabi
Error: Missing Dependency: libraw1394.so.5 is needed by package libdc1394
Error: Missing Dependency: libraw1394.so.5 is needed by package ffmpeg

Someone has an ideia for this issue.

Thanks a lot in advance.

Eustáchio




More information about the users mailing list