[SECURITY] Fedora Core 2 Update: mozilla-1.7.6-1.2.2

Paul Howarth paul at city-fan.org
Mon Mar 28 10:26:03 UTC 2005


On Sat, 2005-03-26 at 10:28 -0500, David Curry wrote:
> Paul Howarth wrote:
> 
> >On Fri, 2005-03-25 at 21:47 -0500, David Curry wrote:
> >  
> >
> >>Is anyone else having a problem applying the latest Mozilla security 
> >>upgrades?  I have used Up2date to fully maintain my system.  Yet, in 
> >>attempting to apply the subject update, I am advised of a package 
> >>dependency problem.  The message reads, "Unresolvable chain of 
> >>dependencies: mozilla-1.7.6-1.2.2 reauires desktop-file-utils >=0.9  
> >>
> >>The desk-file-utils package installed on my system is numbered 0.4-2 and 
> >>http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/i386/ 
> >>does not list any updates.   How does one resolve the descrepancy here?
> >>    
> >>
> >
> >A workaround you could use would be to install the FC3 version of
> >desktop-file-utils, which would satisfy the dependency.
> >
> >Paul.
> >  
> >
> Thanks, Paul.  It seems that the upgrade has been withdrawn at this 
> point and no longer available for download so the issue is moot for the 
> moment.  For future reference, though, am I correct in thinking that I 
> would need to rebuild the desktop-file-utils rpm for FC2 before applying it?

It's usually a good idea to do this but in this particular case the
binary RPM installs cleanly and so there's no need to do the rebuild.
However, the point is moot if there are suitable updates available that
don't have the FC3 dependency in them.

Paul.
-- 
Paul Howarth <paul at city-fan.org>




More information about the users mailing list