upgrade FC3 to FC4 now problem with up2date

akonstam at trinity.edu akonstam at trinity.edu
Tue Nov 15 14:26:39 UTC 2005


On Tue, Nov 15, 2005 at 05:40:20AM -0800, Rick Lim wrote:
> Just upgraded from FC3 to FC4 and now I have this problem with up2date
> 
> I have already tried the rm /var/lib/rpm/__* and rpm --rebuilddb
> Any suggestions?
> 
> 
> # up2date -u
> rpmdb: Program version 4.3 doesn't match environment version
> error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database
> environment version mismatch
> error: cannot open Packages index using db3 -  (-30974)
> error: cannot open Packages database in /var/lib/rpm
> An error has occurred:
> exceptions.TypeError
> 
> -- 
For the    404th time or maybe its the 408th, don't use up2date, use
yum update.
-- 

=======================================================================
Football builds self-discipline.  What else would induce a spectator to
sit out in the open in subfreezing weather?
-------------------------------------------
Aaron Konstam
Computer Science
Trinity University
telephone: (210)-999-7484




More information about the users mailing list