[FC4]: both RPM and YUM crash with errors on FC4 after upgrade.

Gilbert Sebenste sebenste at weather3.admin.niu.edu
Fri Apr 7 17:31:07 UTC 2006


hi Ian,

> You didn't want to do "-i".  That installs the new version without removing the
> old one.  You almost certainly now have two rpm packages installed.  If you
> could do "rpm -q" you would see them.

I did, and I just had the new version on there. I did a "-i" to reinstall 
the new version.

> My guess is that there is a version mismatch between rpm and berkeley db,
> probably because of old versions.  It is  suspicious that it is trying to use
> db3 since FC4 only used db 4.3 and doesn't even have db3 available.

Yep, so I removed the old db files.

> Reinstalling the whole OS is probably the best option.  You may also be able to
> upgrade from the CDs.

Or, removing the old db files and doing an

rpm --rebuilddb

> Try seeing what /lib/libdb*, /usr/lib/librpm*, /usr/bin/rpm exist.  Try moving
> the old versions out of the way and see if that fixes the problem.  Try moving
> the new versions out of the way and see if that fixes the problem.  If you do
> get rpm working, remove the duplicate packages.

It now works. Thanks!

*******************************************************************************
Gilbert Sebenste                                                     ********
(My opinions only!)                                                  ******
*******************************************************************************




More information about the users mailing list