Steve Brueckner steve at
Fri Apr 7 18:24:42 UTC 2006

Todd Zullinger wrote:
> Steve Brueckner wrote:
>> I need to install perl-Carp-Clan using rpm (not yum) but it gives me
>> this error: 
>> # rpm -ivh perl-Carp-Clan-5.3-1.2.noarch.rpm
>> error: Failed dependencies:
>> 	perl(:MODULE_COMPAT_5.8.8) is needed by
>> perl-Carp-Clan-5.3-1.2.noarch 
> It looks like the perl-Carp-Clan rpm you have there was compiled for
> a newer perl than is installed with FC4.  Is there some reason you
> don't just install the perl-Carp-Clan rpm from core?  You could do
> yum install perl-Carp-Clan or you could grab the rpm from the CD or a
> mirror and install it manually with rpm.    
> - --
> Todd 

Argh, I had accidentally grabbed the Carp::Clan rpm off my FC5 DVD instead
of my FC4 DVD.  Such carelessness!  Thanks Todd for making me double check
my rpm source.

Thanks also to Paul for answering earlier; I'm glad I don't have to get into
rebuilds, though.

Steve Brueckner, ATC-NY

More information about the users mailing list