PPSCSI anyone?

Kevin Flynn flavor_tagger at hotmail.com
Tue Apr 18 22:08:03 UTC 2006

My HP 5100c scanjet requires the ppSCSI driver for use with SANE.  I 
downloaded a kernel patch containing the ppSCSI driver from 

However, I am unable to use this patch to build a custom 2.6.16-1.2080 
kernel.  I've tried two methods of applying the patch to the kernel source 
(obtained after installing the kernel .src.rpm):
  1.  replace original linux-2.6.16.tar.bz2 source tree (in rpmbuild/SOURCES 
directory) with patched version
  2.  modify spec file to apply above patch after the other SCSI patches are 

The patch applies cleanly using either method, but the final result is the 
same:  rpmbuild fails at the prep stage with the following error:

make[1]: *** [nonint_oldconfig] Error 1
make: *** [nonint_oldconfig] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.48302 (%prep)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.48302 (%prep)

Does anyone have any insight into this error?  Or better yet, has anyone be 
able to build the ppSCSI driver against a recent Fedora kernel?

Thanks for any help.

FREE pop-up blocking with the new MSN Toolbar – get it now! 

More information about the users mailing list