Will it cause Java problem in FC4

Wong Kwok-hon kwokhon at gmail.com
Fri Feb 3 05:20:55 UTC 2006


On 2/3/06, Stanton Finley <stanfinley at comcast.net> wrote:
> On Fri, 2006-02-03 at 12:56 +0800, Wong Kwok-hon wrote:
> > Hello!
> >
> > After I installed the JAVA JRE as followed from Installation Notes of
> > FC4. But following messages displayed for JRE which displayed only the
> > 1.4.2 is  best but I am tested ok in sun.com which displayed 1.5-06.
> > Did I missed some setting ? Or any affect on using java programs ?
> >
> > Thank you.
> >
> > Wong Kwok Hon
> >
> > = quote started =
> > [root at ringofc3 ~]# alternatives --config java
> >
> > There are 2 programs which provide 'java'.
> >
> >   Selection    Command
> > -----------------------------------------------
> > *  1           /usr/lib/jvm/jre-1.4.2-gcj/bin/java
> >  + 2           /usr/java/jre1.5.0_06/bin/java
> >
> > Enter to keep the current selection[+], or type selection number: 2
> >
> > [root at xxx ~]# alternatives --display java
> > java - status is manual.
> >  link currently points to /usr/java/jre1.5.0_06/bin/java
> > /usr/lib/jvm/jre-1.4.2-gcj/bin/java - priority 1420
> >  slave rmiregistry: /usr/lib/jvm/jre-1.4.2-gcj/bin/rmiregistry
> >  slave jre_exports: /usr/lib/jvm-exports/jre-1.4.2-gcj
> >  slave jre: /usr/lib/jvm/jre-1.4.2-gcj
> > /usr/java/jre1.5.0_06/bin/java - priority 2
> >  slave rmiregistry: (null)
> >  slave jre_exports: (null)
> >  slave jre: (null)
> > Current `best' version is /usr/lib/jvm/jre-1.4.2-gcj/bin/java.
> >
> > = quote ended =
> >
> This message probably means that because the jre-1.4.2-gcj is the open
> source implementation of Java that is included by default with your
> Fedora Core installation it is "best" (in the sense that it is free and
> open source and not proprietary or otherwise encumbered). However many
> people, including myself, need the proprietary Sun Java to do what we
> need to do with Java.
>
> Stanton Finley
> http://stanton-finley.net/

So would it affect the Java application running in Java 1.5 ?
Would the application choose 1.5 not the 1.4.2 ?

Wong Kwok Hon




More information about the users mailing list