kmod-nvidia for non-standard fedora kernel?

Terry Snyder terryjr386 at
Sat Jul 1 01:10:13 UTC 2006

On 6/30/06, Todd Zullinger <tmz at> wrote:
> Hash: SHA1
> Lonni J Friedman wrote:
> > On 6/30/06, Terry Snyder <terryjr386 at> wrote:
> >>I am using the 16k stack size kernel from Linuxant because of the my
> >>wireless network card.  I have everything working but when I used
> >>the default kernels from fedora I could use the kmod-nvidia from
> >>livina worked like a charm, but now I would like the same for this
> >>16k kernel.  Where or how can I create one for this kernel.  I can't
> >>play any videos on the 16k kernel mplayer says there isn't any
> >>resources for the video driver to play the video.
> >
> > Does livna provide an SRPM?  If so, rebuild it, and you'll be set.
> > If not, just install the official nvidia driver package from
> >
> They do.  I rebuilt the nvidia package before, though I can't recall
> if it was on FC4 or FC5.  But it worked with only a few minor mods to
> the specfile as I recall (somewhat documented mods at that).
> - --
> Todd        OpenPGP -> KeyID: 0xD654075A | URL:
> ======================================================================
> The power of accurate observation is frequently called cynicism by
> those who don't have it.
>     -- George Bernard Shaw
> Version: GnuPG v1.4.3 (GNU/Linux)
> Comment: When crypto is outlawed bayl bhgynjf jvyy unir cevinpl.
> iG0EARECAC0FAkSlT40mGGh0dHA6Ly93d3cucG9ib3guY29tL350bXovcGdwL3Rt
> ei5hc2MACgkQuv+09NZUB1rs8gCdFLy/SdrnzYkTP4CTD/tsvoOEs9sAn3vT+8Pk
> =HuKr
> --
> fedora-list mailing list
> fedora-list at
> To unsubscribe:

I downloaded the src.rpm files but now I get this as an error message when I
try to make the rpms.  What do I need to do to fix this?

]$ rpmbuild -ba nvidia-kmod.spec --target $(uname -m) --without userland
Building target platforms: i686
Building for target i686
error: Failed build dependencies:
        kernel-devel-i686 = 2.6.17-1.2139_FC5 is needed by
        kernel-smp-devel-i686 = 2.6.17-1.2139_FC5 is needed by
        kernel-kdump-devel-i686 = 2.6.17-1.2139_FC5 is needed by

I am really new at creating rpm files  I have been really lucky in the fact
that if the rpm didn't work I would do a make install from source.

My ]$ uname -r -m is.
2.6.17-1.2139_FC5.stk16smp i686

Terry Snyder Jr
Computer Support Specialist
Linux (Red Hat, Fedora Core), Windows, Mac
Fedora Core 5  3 users,  load average: 0.19, 0.30, 0.28
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the users mailing list