WORKAROUND: nfs-utils/librpcsecgss.so.1/libgssapi.so.1 dependency issue

Bob Goodwin bobgoodwin at wildblue.net
Sat Jul 1 14:15:27 UTC 2006


Paul Howarth wrote:
> The problem that has spawned numerous threads today, namely:
>
> --> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
> --> Processing Dependency: libgssapi.so.1 for package: nfs-utils
> --> Finished Dependency Resolution
> Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
> Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils
>
> is due to a release candidate version of nfs-utils having previously been released into the updates-released repository without having followed the Fedora Package Naming Guidelines:
>
> http://www.fedoraproject.org/wiki/Packaging/NamingGuidelines?highlight=%28Pre-Release%29
>
> This "release candidate" version is now installed on many people's machines and is seen by rpm and yum as "newer" than the recently-released version that should be replacing it.
>
> So rpm and yum do not want to replace the release candidate version with the new version that is linked against new versions of librpcsecgss and libgssapi.
>
> Hence the problems.
>
> What's hard to believe is that this problem is well-known and has been affecting people using the updates-testing and development repos, yet still the new release was made, which has precipitated these dependency issues.
>
> Anyway, on to the workaround. I have rebuilt the latest nfs-utils update but have used a version number that will be seen by rpm and yum as "newer" than the release candidate. Hence, updates will work as intended.
>
> I only have an i386 build machine, so if anyone can rebuild the package for other architectures, it would be useful.
>
> Here's how to install:
>
> # rpm --import http://www.city-fan.org/ftp/contrib/depfixes/CITY-FAN.ORG-GPG-KEY
> # wget http://www.city-fan.org/ftp/contrib/depfixes/nfs-utils-1.0.8.z.RELEASE-1.FC5.i386.rpm
> # yum localinstall nfs-utils-1.0.8.z.RELEASE-1.FC5.i386.rpm
> # rm nfs-utils-1.0.8.z.RELEASE-1.FC5.i386.rpm
>
> Before doing this, consider for yourself whether you trust me (someone you may only know from this mailing list) to supply packages that are installed on your system. If you don't trust me, don't do it.
>
> Related bugzilla entries:
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196321
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196359
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=197219
>
> The long term fix will happen when upstream release version 1.0.9 of nfs-utils.
>
> Paul.
>
>   
Worked perfectly!

Thanks.

Bob Goodwin




More information about the users mailing list