libgssapi.so.1 is needed by package nfs-utils

Kam Leo kam.leo at gmail.com
Sun Jul 2 21:31:01 UTC 2006


On 7/2/06, Jeff Vian <jvian10 at charter.net> wrote:
> On Fri, 2006-06-30 at 22:03 -0800, Kam Leo wrote:
> > On 6/30/06, Mathew Snyder <msnyder at servervault.com> wrote:
> > > I was running yum update when I encountered this:
> > >
> > > --> Populating transaction set with selected packages. Please wait.
> > > ---> Package nfs-utils-lib.i386 0:1.0.8-4.FC5 set to be updated
> > > --> Running transaction check
> > > --> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
> > > --> Processing Dependency: libgssapi >= 0.9 for package: nfs-utils-lib
> > > --> Restarting Dependency Resolution with new changes.
> > > --> Populating transaction set with selected packages. Please wait.
> > > ---> Package libgssapi.i386 0:0.9-1.FC5 set to be updated
> > > --> Running transaction check
> > > --> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
> > > --> Processing Dependency: libgssapi.so.1 for package: nfs-utils
> > > --> Finished Dependency Resolution
> > > Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
> > > Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils
> > >
> > > I did a search online to find out what provides the files just to make
> > > sure and found that nfs-utils-lib provides it.  If I have that installed
> > >
> > > [root at rt RT_Setup]# rpm -qa | grep nfs-utils
> > > nfs-utils-1.0.8.rc2-5.FC5
> > > nfs-utils-lib-1.0.8-3.1
> > >
> > > why would it be giving me this error?  I didn't have this problem until
> > > tonight.  I've been testing the build of the server this occurred on
> > > over the course of two weeks and this is the first time this has
> > > occurred.  Is there a problem with the yum repositories or the packages
> > > itself?
> > >
> > > --
> > > Mathew Snyder
> > > Systems Administrator
> > > Network+
> > > ServerVault TechOps
> > >
> >
> > Your experience is not unique. You can a) file a bug report ("a good
> > thing"), b) exclude nfs-utils and update the remaining packages, c)
> > wait a day or two and hope that it is a repository synchronization
> > problem or d) do nothing.
> >
>
> I think this is the cause of the problem.
> --------------------------------------------------
> ncftp .../core/updates/5/x86_64 > ls nfs*
> nfs-utils-1.0.8-2.fc5.x86_64.rpm
> nfs-utils-1.0.8.rc2-5.FC5.x86_64.rpm
> nfs-utils-lib-1.0.8-4.FC5.x86_64.rpm
> nfs-utils-lib-devel-1.0.8-4.FC5.x86_64.rpm
> -------------------------------------------------
> The updates repo for FC5/x86_64 has an updated nfs-utils-lib package but
> not the matching (by naame) nfs-utils package.  The dates show the
> nfs-utils-1.0.8-2 is newer than the the rc2 package, but it still will
> not update with yum.
>
> I would class this a distribution bug, and until this is fixed the only
> way I have been able to do an update is to exclude both nfs-utils\* and
> libgssapi.
>
> After looking at this and what was happening I fixed it by doing a bit
> of work with rpm.
> 1.  downloaded the latest nfs-utils, nfs-utils-lib and libgssapi
> packages.
>
> 2.  did an rpm -F  with all the 3 packages above in a single
> transaction. (The -F should have had rpm erase the old package, but see
> step 3)
>
> 3.  did a yum search with the following results:
> [root at raptor ~]# yum search nfs-utils libgssapi | grep installed
> libgssapi.x86_64            0.9-1.FC5              installed
> libgssapi.x86_64            0.7-2.1                installed
> nfs-utils.x86_64            1:1.0.8-2.fc5          installed
> nfs-utils-lib.x86_64        1.0.8-3.1              installed
> nfs-utils-lib.x86_64        1.0.8-4.FC5            installed
>
> This shows that nfs-utils-lib and libgssapi both have multiple versions
> installed.
>
> 4. I now had to identify which package names to use for cleanup, so I
> did this:
>
> [root at raptor ~]# rpm -qa nfs-utils-lib
> nfs-utils-lib-1.0.8-3.1
> nfs-utils-lib-1.0.8-4.FC5
> [root at raptor ~]# rpm -qa libgssapi
> libgssapi-0.9-1.FC5
> libgssapi-0.7-2.1
>
> 5. I then removed the old packages.
>
> [root at raptor ~]# rpm -e nfs-utils-lib-1.0.8-3.1
> [root at raptor ~]# rpm -e libgssapi-0.7-2.1
>
> 6.  To test that the yum problem was now fixed I did another yum update
> and it came back with the message that there was nothing to do.
>
> Success in the update, and a workaround that can be used, but this is a
> packaging bug that needs to be fixed so the yum updates work properly.
>

There are actually two bugs which need fixing. The first, nfs-utils
packaging, will be fixed fairly quickly. The second, yum
--exclude=nfs-utils*, may take a while.




More information about the users mailing list