SAS on FC5

Ed Greshko Ed.Greshko at
Thu May 11 00:48:21 UTC 2006

Yuandan Zhang wrote:

> Hi, Has anyone sucessfully installed SAS 8.1 or SAS 9.1 on FC5? I have
> difficulty to install SAS 8.1.

> The company support said
> "I have checked our system requirements for Linux and unfortunately your
> operating system is not compatible with SAS.

That just about sums it up, doesn't it?

> Software Requirements
> Operating System
> Red Hat Linux 7.1
> Important: Most other distributions of Linux will not work.
> SAS relies on the following operating system components:
> ?? Linux kernel 2.4.x

FC5 is a 2.6 kernel.

> ?? GNU libc 2.2.x (with LDT threads)

Standard is now POSIX treads I believe...

> Installations that include different levels of the kernel and libc may
> be compatible with SAS software,
> but they have not been tested. "

Anyway, you can try one thing:

First, make sure you that you have all that compatibility packages
installed.  Next, prior to trying to run SAS do an
export LD_ASSUME_KERNEL=2.4.1

Good luck.  You're going to need it.  :-)


To think contrary to one's era is heroism.  But to speak against it is
		-- Eugene Ionesco

More information about the users mailing list