FC6 update mystery

Aaron Konstam akonstam at sbcglobal.net
Sun Nov 5 16:26:46 UTC 2006


On Sun, 2006-11-05 at 20:35 +0530, Rahul Sundaram wrote:
> Aaron Konstam wrote:
> > On Fri, 2006-11-03 at 20:35 +0530, Rahul Sundaram wrote:
> >> Aaron Konstam wrote:
> >>
> >>> I am sorry I got too frustrated to give all the facts. None of the
> >>> development repos are enabled. However right now I have a notice of 17
> >>> updates and they will not install because of missing dependencies. Why
> >>> are these dependencies just installed?
> >> Not enough details yet. Post the yum output.
> >>
> >> Rahul
> >>
> > Fair enough . Here are the output of yum update
> 
> This seems to be a upgrade from Fedora Core 5. How did you upgrade?. 
> There is several FC5 packages in your system which are interefering with 
> the update process. Look at packages with "fc5" in their name, remove 
> them and install the FC6 version.
> 
> Rahul
> Thanks for the resposne. Ther certainly seem to be fc5 rpms in the system but how did they get there. 
I did not upgrade from fc5. I did a clean install of fc6. Any fc5 rpms
were placed there by the yum process or piyut or the system updates. I
will install the whole thing again thing again to be sure and we will
see what happens. I as you already know are not perfect and maybe I hit
update instead of install during the installation process but that was
not my intent. But you may have found the problem. We will see.
> 
> > 
> > Loading "installonlyn" plugin
> > Setting up Update Process
> > Setting up repositories
> > Reading repository metadata in from local files
> > Excluding Packages in global exclude list
> > Finished
> > Resolving Dependencies
> > --> Populating transaction set with selected packages. Please wait.
> > ---> Package libvte-java.i386 0:0.12.1-5.fc5 set to be updated
> > ---> Package libvirt.i386 0:0.1.7-3.FC5 set to be updated
> > ---> Package kdenetwork.i386 7:3.5.5-0.1.fc5 set to be updated
> > ---> Package kde-i18n-Hebrew.noarch 1:3.5.5-0.1.fc5 set to be updated
> > ---> Package kdemultimedia.i386 6:3.5.5-0.1.fc5 set to be updated
> > ---> Package libvirt-python.i386 0:0.1.7-3.FC5 set to be updated
> > ---> Package kdepim.i386 6:3.5.5-0.1.fc5 set to be updated
> > ---> Package kdebase.i386 6:3.5.5-0.1.fc5 set to be updated
> > ---> Package kdegraphics.i386 7:3.5.5-0.1.fc5 set to be updated
> > ---> Package libgtk-java.i386 0:2.8.7-2.fc5 set to be updated
> > ---> Package kdeutils.i386 6:3.5.5-0.1.fc5 set to be updated
> > ---> Downloading header for cvs to pack into transaction set.
> > ---> Package cvs.i386 0:1.11.22-6.fc5 set to be updated
> > ---> Downloading header for xen to pack into transaction set.
> > ---> Package xen.i386 0:3.0.3-1.fc5 set to be updated
> > ---> Package arts.i386 8:1.5.5-0.1.fc5 set to be updated
> > ---> Package kdeartwork.i386 0:3.5.5-0.1.fc5 set to be updated
> > ---> Package kdeaccessibility.i386 1:3.5.5-0.1.fc5 set to be updated
> > ---> Package kdelibs.i386 6:3.5.5-0.2.fc5 set to be updated
> > ---> Package libgconf-java.i386 0:2.12.4-5.fc5 set to be updated
> > ---> Package kdeaddons.i386 0:3.5.5-0.1.fc5 set to be updated
> > ---> Package frysk.i686 0:0.0.1.2006.10.30.rh1-1.fc5 set to be updated
> > --> Running transaction check
> > --> Processing Dependency: libImlib.so.11 for package: kdegraphics
> > --> Processing Dependency: xscreensaver-gl-extras for package:
> > kdeartwork
> > --> Processing Dependency: xscreensaver-base for package: kdeartwork
> > --> Processing Dependency: libgcj.so.7 for package: frysk
> > --> Processing Dependency: libgcj.so.7 for package: libgtk-java
> > --> Processing Dependency: xscreensaver-extras for package: kdeartwork
> > --> Processing Dependency: libgcj.so.7 for package: libvte-java
> > --> Processing Dependency: libvte.so.4 for package: libvte-java
> > --> Processing Dependency: libdbus-1.so.2 for package: kdebase
> > --> Processing Dependency: libgcj.so.7 for package: libgconf-java
> > --> Restarting Dependency Resolution with new changes.
> > --> Populating transaction set with selected packages. Please wait.
> > ---> Package xscreensaver-base.i386 1:5.01-3.fc6 set to be updated
> > ---> Package imlib.i386 1:1.9.13-30.fc6 set to be updated
> > ---> Package xscreensaver-gl-extras.i386 1:5.01-3.fc6 set to be updated
> > ---> Package xscreensaver-extras.i386 1:5.01-3.fc6 set to be updated
> > --> Running transaction check
> > --> Processing Dependency: libgmodule-1.2.so.0 for package: imlib
> > --> Processing Dependency: libgdk-1.2.so.0 for package: imlib
> > --> Processing Dependency: libgcj.so.7 for package: frysk
> > --> Processing Dependency: gtk+ >= 1:1.2 for package: imlib
> > --> Processing Dependency: libgcj.so.7 for package: libgtk-java
> > --> Processing Dependency: libgtk-1.2.so.0 for package: imlib
> > --> Processing Dependency: libgcj.so.7 for package: libvte-java
> > --> Processing Dependency: libvte.so.4 for package: libvte-java
> > --> Processing Dependency: libglib-1.2.so.0 for package: imlib
> > --> Processing Dependency: libdbus-1.so.2 for package: kdebase
> > --> Processing Dependency: libgcj.so.7 for package: libgconf-java
> > --> Restarting Dependency Resolution with new changes.
> > --> Populating transaction set with selected packages. Please wait.
> > ---> Package gtk+.i386 1:1.2.10-55.fc6 set to be updated
> > ---> Package glib.i386 1:1.2.10-23.fc6 set to be updated
> > --> Running transaction check
> > --> Processing Dependency: libgcj.so.7 for package: frysk
> > --> Processing Dependency: libgcj.so.7 for package: libgtk-java
> > --> Processing Dependency: libgcj.so.7 for package: libvte-java
> > --> Processing Dependency: libvte.so.4 for package: libvte-java
> > --> Processing Dependency: libdbus-1.so.2 for package: kdebase
> > --> Processing Dependency: libgcj.so.7 for package: libgconf-java
> > --> Finished Dependency Resolution
> > Error: Missing Dependency: libgcj.so.7 is needed by package frysk
> > Error: Missing Dependency: libgcj.so.7 is needed by package libgtk-java
> > Error: Missing Dependency: libgcj.so.7 is needed by package libvte-java
> > Error: Missing Dependency: libvte.so.4 is needed by package libvte-java
> > Error: Missing Dependency: libdbus-1.so.2 is needed by package kdebase
> > Error: Missing Dependency: libgcj.so.7 is needed by package
> > libgconf-java
> > 
> > 
> > --
> > =======================================================================
> > Murphy's Laws: (1) If anything can go wrong, it will. (2) Nothing is as
> > easy as it looks. (3) Everything takes longer than you think it will.
> > =======================================================================
> > Aaron Konstam telephone: (210) 656-0355 e-mail: akonstam at sbcglobal.net
> > 
> 
--
=======================================================================
The difference between science and the fuzzy subjects is that science
requires reasoning while those other subjects merely require
scholarship. -- Robert Heinlein
=======================================================================
Aaron Konstam telephone: (210) 656-0355 e-mail: akonstam at sbcglobal.net




More information about the users mailing list