broken yum after latest yum update

Konstantin Svist fry.kun at gmail.com
Sat Dec 1 21:58:31 UTC 2007


Michael Schwendt wrote:
> On 01/12/2007, Konstantin Svist <fry.kun at gmail.com> wrote:
>   
>> $ ldd /usr/bin/python
>>         linux-gate.so.1 =>  (0x00110000)
>>         libpython2.5.so.1.0 => /usr/local/lib/libpython2.5.so.1.0
>>     
>
> Boom! As I wrote, your local lib install overrides the system lib,
> which breaks badly if they are incompatible. If you want to avoid
> that, you need to fix your ld.so* configuration.
>   

So how do I "fix" it?
I'm guessing something in the process of compilation of /usr/local 
version...


May be worthwhile mentioning:
on a 64bit install, python behaves differently: when LD_LIBRARY_PATH is 
set to /usr/local/lib, it uses that library; when it's not set, it uses 
/usr/lib64 version






More information about the users mailing list