yum BUG on update from FC6 to F7

Martin Marques martin at marquesminen.com.ar
Tue Dec 4 19:57:12 UTC 2007


I'm getting some annoying errors when trying to upgrade directly with
yum from FC6 to F7.

Basically there's a problem with python and authconfig and gamin-python.
What's really strange is that if I try to update directly with the rpm
file yum says that authconfig isn't installed, but rpm thinks diferently.

[root at linus ~]# yum update
/var/fedora/Fedora/authconfig-5.3.13-4.fc7.i386.rpm
Loading "downloadonly" plugin
Loading "priorities" plugin
Loading "kmdl" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
688 packages excluded due to repository priority protections
Examining /var/fedora/Fedora/authconfig-5.3.13-4.fc7.i386.rpm:
authconfig - 5.3.13-4.fc7.i386
/var/fedora/Fedora/authconfig-5.3.13-4.fc7.i386.rpm: does not update
installed package.
No Packages marked for Update/Obsoletion
[root at linus ~]# rpm -q authconfig
authconfig-5.3.18-0.1.fc6

Any ideas?




More information about the users mailing list