FC7 Kernel upgrade

Matthew Saltzman mjs at CU.CLEMSON.EDU
Thu Jun 14 12:24:26 UTC 2007


On Thu, 2007-06-14 at 12:34 +0200, Ralf Corsepius wrote:
> On Thu, 2007-06-14 at 10:59 +0200, Sjoerd Mullender wrote:
> 
> > I tried updating two systems this morning.  One refused because it
> > required a newer mkinitrd than was available, the other went ahead,
> > despite there not being a newer mkinitrd.  Both are i686 systems, but
> > the one that succeeded still had a FC6 kernel on it (not used though,
> > and it was deleted by the update).
> 
> AFAICT from experimenting, yum bogusly updates despite the broken deps
> on machines which have more than 1 older kernel installed, but refuses
> to update if exactly 1 older kernel is installed.

As a counterpoint, I have a system with the first F7 kernel and the last
FC6 kernel and command-line yum refused to upgrade.

As a workaround, enabling updates-testing repo and specifying an upgrade
to kernel and/or kernel-devel will pull in the mkinitrd and nash
depedencies.

BTW, for everyone complaining about yum upgrading despite dependencies,
are you using command-line yum or the GUI tool?  I've had incidents
where pup installed packages without including their dependencies, but
I've never (yet) seen command-line yum do it.

> 
> Ralf
> 
> 
> 
> 
-- 
                Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs




More information about the users mailing list