Trouble mounting NFS shares in %post script of a kickstart FC6 install

Charles Curley charlescurley at charlescurley.com
Fri Mar 23 21:41:38 UTC 2007


On Fri, Mar 23, 2007 at 01:55:52PM -0400, Peter Schwenk wrote:
> 
>    Just in case anyone is wondering...
> 
>    It turns out that somewhere along the way during a kickstart install for
>    FC6, the portmap program is killed, so by the time the install gets to the
>    %post script, NFS mounts can't happen.  I found this out by looking at the
>    F4 terminal messages that indicated that the mount operation was trying to
>    contact the portmapper on localhost.

Thank you.

I think that's a bug. If you haven't already done so, would you please
bugzilla it? I do exactly as you do, and nfs mount a directory with
scripts, files and other goodies for %post processing.

Also, does shutting off portmapper affect an NFS mounted installation?
I recall doing several installations of FC6 and not having any
problems with it (but no %post processing on those).


-- 

Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.fedoraproject.org/pipermail/users/attachments/20070323/5a3d55e6/attachment-0002.bin 


More information about the users mailing list