error updating rpm-libs FC6

Michael Schwendt mschwendt at
Wed Nov 14 12:03:29 UTC 2007

On 13/11/2007, Mark Haney <mhaney at> wrote:
> I did an update last week of my last FC6 box here and the rpm-libs
> update bombed.  I didn't think anything about it because I was having
> issues with my firewall and with that box outside it, I was getting
> spotty connectivity.
> However, I fixed that this weekend, and rpm-libs still bombs.  Well it
> doesn't bomb, it just doesn't finish.  I get this when I ctrl-c:
> error: %pre(rpm- scriptlet failed, signal 2
> error:   install: %pre scriptlet failed (2), skipping rpm-
> Anyone seen this problem?


$ rpm --query --scripts rpm

Look at the %preinstall scriptlet code. Maybe you find a reason why
the commands in the script don't work in your environment.

More information about the users mailing list