wpa_supplicant update on f7 broken with the b43 driver

Mike Leahy mgleahy at alumni.uwaterloo.ca
Thu Nov 22 00:24:15 UTC 2007

Hello list,

I had some trouble connecting via wireless on my F7-x86_64 setup after I
had run updates, which included wpa_supplicant version 1:0.5.7-4.fc7.
It took a while to narrow down the problem.  I could use commandline
tools to connect to unprotected routers without using wpa_supplicant,
and ultimately I noticed this if I restarted the wpa_supplicant service:

Stopping wpa_supplicant:                                   [  OK  ]
Starting wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf,
-iwlan0, -DwextSIOCSIFFLAGS: No such device
Could not set interface 'wlan0' UP
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -                              [  OK  ]

So while there were errors during bootup as well, the service apparently
starts 'ok', and the startup progress interface didn't display the
details.  After I reverted to the original version of wpa_supplicant
that came with F7 (0.5.7-2), everything works fine again.  Is this just
a bug that will likely go away in future versions of wpa_supplicant?

I'm using the b43 driver with a bcm4309 wireless chip...which has worked
fairly well other than this new problem.


More information about the users mailing list