Script errors while livecd-creator is running yum

dexter dex.mbox at googlemail.com
Wed Dec 3 18:31:53 UTC 2008


2008/12/3 Bruno Wolff III <bruno at wolff.to>:
> On Wed, Dec 03, 2008 at 16:16:03 +0000,
>  dexter <dex.mbox at googlemail.com> wrote:
>>
>> A correct assumption, but all the times I've seen such errors its been
>> down to bad package selection in kickstart files! are you using the
>> official games kickstart as a base or is it totally homebrew?
>
> Pretty much the official one. I had to comment out starfighter which has
> been removed. It includes fedora-live-base.ks so I would expect it to
> install things it needs.

Indeed

> Something could be wrong with the repo build as in the short term I have
> been using a repo made from f10 and koji packages, but I didn't see any errors
> for the groups. (I did have that issue previously, but had fixed it.)

I've also pulled the latest from koji to my local repo then re-run
createrepo on it to no detriment.

> Should I expect core-utils to be installed before any of the problem
> packages? If so I could verify that and see if that looks like the cause.
> Also the references to touch all seemed to be missing a path; could there
> be a default path issue?

Yes its part of the @core group so it should be part of all normal spins!
It could be a path issue like you say but from the powermanger.spec in F9
gtk-update-icon-cache is given a full path and touch isn't and they both fail?
weird, file bugz on livecd-creator (post number) or ask again on the
livecd-list.

> %post
> touch --no-create %{_datadir}/icons/hicolor || :
> %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :

...dex




More information about the users mailing list