Can't get photos from camera -

Bob Goodwin bobgoodwin at wildblue.net
Mon Feb 4 21:14:05 UTC 2008


gphoto2 is giving me the following error messages.  I used it a few days 
ago with a different camera and it worked without a hitch.

        gphoto2 --auto-detect
        Model                         
        Port                                           
        ----------------------------------------------------------
        USB PTP Class Camera           usb:           
        USB PTP Class Camera           usb:005,008    
        [root at box6 ~]# gphoto2 --list-files
                                                                                      

        *** Error ***             
        PTP I/O error

        *** Error ***             
        An error occurred in the io-library ('Unspecified error'): The
        supplied vendor or product id (0x0,0x0) is not valid.
        *** Error (-1: 'Unspecified error') ***      

        For debugging messages, please use the --debug option.
        Debugging messages may help finding a solution to your problem.
        If you intend to send any error or debug messages to the gphoto
        developer mailing list <gphoto-devel at lists.sourceforge.net>,
        please run
        gphoto2 as follows:

            env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt
        --list-files

        Please make sure there is sufficient quoting around the arguments.




        gphoto2 --get-all-files
                                                                                      

        *** Error ***             
        PTP I/O error

        *** Error ***             
        An error occurred in the io-library ('Unspecified error'): Could
        not query kernel driver of device.
        *** Error (-1: 'Unspecified error') ***      

        For debugging messages, please use the --debug option.
        Debugging messages may help finding a solution to your problem.
        If you intend to send any error or debug messages to the gphoto
        developer mailing list <gphoto-devel at lists.sourceforge.net>,
        please run
        gphoto2 as follows:

            env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt
        --get-all-files

        Please make sure there is sufficient quoting around the arguments.

Man gphoto2 is not much help or perhaps beyond my comprehension.

Any suggestions appreciated.

Bob Goodwin




More information about the users mailing list