F8-xen: Problem with PCI-Passthrough {Scanned}

Christian Exner christian.exner at cex-development.de
Tue Mar 4 11:04:53 UTC 2008


Hi everybody,

i'am not able to configure a working pci passthrough under f8.

Here some Parameters:
- Using virsh to manage my guests
- Xen host is running 2.6.21.7-2.fc8xen (SMP) from 15. Feb. 2008 12:39:36
- Virsh version: libvir 0.4.0/ API xen 3.0.1/ Hypervisor 3.1.0
- Guest is setup with virt-install

XML-Configuration of guest locks like this:
/<domain type='xen' id='-1'>
  <name>VM6</name>
  <uuid>3a84bc19-69fe-370d-8726-508a4714ceae</uuid>
  <bootloader>/usr/bin/pygrub</bootloader>
  <os>
    <type>linux</type>
  </os>
  <memory>131072</memory>
  <vcpu>1</vcpu>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <interface type='bridge'>
      <source bridge='br2-dmz'/>
      <target dev='vif-1.0'/>
      <mac address='00:16:3e:42:23:56'/>
      <script path='vif-bridge'/>
    </interface>
    <disk type='block' device='disk'>
      <driver name='phy'/>
      <source dev='/dev/VolGroup01/lv_comm-01_xvda'/>
      <target dev='xvda'/>
    </disk>
    <disk type='block' device='disk'>
      <driver name='phy'/>
      <source dev='/dev/VolGroup01/lv_comm-01_swap'/>
      <target dev='xvdb'/>
    </disk>
    <disk type='block' device='disk'>
      <driver name='phy'/>
      <source dev='/dev/VolGroup01/lv_comm-01_xvdc'/>
      <target dev='xvdc'/>
    </disk>
    <input type='mouse' bus='xen'/>
    <graphics type='vnc' port='5906'/>
    <pci bus='00:04.0' />
  </devices>
</domain>/


After "virsh define" the "<pci bus'00:04.0' />" is not visible in an 
"virsh dumpxml".
"lspci" in the running guest shows no pci devices.

To hide my pci devices from Dom0 i've modified my /etc/rc.d/rc.local as 
described
in some articles found on the web:
/#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.


#
# Initialize xen pciback...
#
modprobe pciback
sleep 2

# AVM FritzCard...
SLOT=0000:00:04.0
# Add a new slot to the PCI Backend's list
echo -n $SLOT > /sys/bus/pci/drivers/pciback/new_slot
# Now that the backend is watching for this slot, bind to it
echo -n $SLOT > /sys/bus/pci/drivers/pciback/bind

# Adaptec SCSI controller...
SLOT=0000:00:04.0
# Add a new slot to the PCI Backend's list
echo -n $SLOT > /sys/bus/pci/drivers/pciback/new_slot
# Now that the backend is watching for this slot, bind to it
echo -n $SLOT > /sys/bus/pci/drivers/pciback/bind

# Start XEN...
#/etc/init.d/xendomains start
/etc/init.d/xend start

/usr/bin/virsh start VM1
/usr/bin/virsh start VM2
/usr/bin/virsh start VM3
/usr/bin/virsh start VM4
/usr/bin/virsh start VM5
#/usr/bin/virsh start VM6


touch /var/lock/subsys/local/


Please can somebody help? ANY hints are welcome!

ThX...
Chris


--
Diese Nachricht wurde auf Viren und andere gefährliche Inhalte untersucht
und ist - aktuelle Virenscanner vorausgesetzt - sauber.
For all your IT requirements visit: http://www.transtec.co.uk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/users/attachments/20080304/19c15c37/attachment-0001.html 


More information about the users mailing list