Building Emacs 23.1 from rawhide for F11

Suvayu Ali fatkasuvayu+linux at
Tue Aug 11 19:50:46 UTC 2009

Hello everyone,

I have been using the emacs build in the rawhide repositories on my F11 
system. (version Now since emacs 23.1 is out, I would like to 
use that. But trying to install the rawhide build pulls in glibc as a 
dependency from rawhide. Since its a crucial library I didn't go ahead 
with it and decided to build from the srpm.

So far I have downloaded the srpm for the rawhide emacs build however 
when I use `sudo yum-builddep --enablerepo=rawhide emacs' yum asks to 
install the build dependencies from rawhide. I understand that must be 
because the rawhide build for emacs was built against them. So what 
would be the ideal way to go ahead with this? Should I just download the 
corresponding packages from the F11 repos? Would that work or will I run 
into problems?

Thanks for any pointers.


Open source is the future. It sets us free.

More information about the users mailing list