grubby error "unable to find a suitable template" when installing kernel-2.6.27.12-78.2.8.fc9

L yuanlux at gmail.com
Fri Jan 30 23:56:50 UTC 2009


On Sat, Jan 31, 2009 at 9:35 AM, L <yuanlux at gmail.com> wrote:

>
>
> On Fri, Jan 30, 2009 at 1:52 AM, Michael Schwendt <mschwendt at gmail.com>wrote:
>
>> On Thu, 29 Jan 2009 09:48:54 +1100, L wrote:
>>
>> > # grub.conf generated by anaconda
>> > #
>> > # Note that you do not have to rerun grub after making changes to this
>> file
>> > # NOTICE:  You do not have a /boot partition.  This means that
>> > #          all kernel and initrd paths are relative to /, eg.
>> > #          root (hd0,1)
>> > #          kernel /boot/vmlinuz-version ro root=/dev/sda2
>> > #          initrd /boot/initrd-version.img
>> > #boot=/dev/sda
>> > default=0
>> > timeout=5
>> > splashimage=(hd0,1)/boot/grub/splash.xpm.gz
>> > hiddenmenu
>> > title Fedora (2.6.27.5-41.fc9.i686)
>> >     root (hd0,1)
>> >     kernel /boot/vmlinuz-2.6.27.5-41.fc9.i686 ro
>> > root=UUID=5e2d514d-487e-4881-aff0-84bc64583555 rhgb quiet
>> >     initrd /boot/initrd-2.6.27.5-41.fc9.i686.img
>> > title Fedora (2.6.27.5-37.fc9.i686)
>> >     root (hd0,1)
>> >     kernel /boot/vmlinuz-2.6.27.5-37.fc9.i686 ro
>> > root=UUID=5e2d514d-487e-4881-aff0-84bc64583555 rhgb quiet
>> >     initrd /boot/initrd-2.6.27.5-37.fc9.i686.img
>>
>> Please attach it (compress it if need be), so it won't be modified with
>> line-breaks. Above it is broken, but I don't want to guess whether that
>> only applies to this mail or also the original file.
>
>
> please find attached are fstab and grub.conf. I suspect this problem has
> something to do with partition /boot mount. Other partitions are mounted
> using UUID=, but partition /boot was not automaticallly mounted. I mounted
> it manually as
> /dev/sda1              /boot                       ext3    defaults
> 1  2
>
>
here are some upput from upgrade kernel


 Loaded plugins: refresh-packagekit
livna                                                    | 2.4 kB
00:00
fedora                                                   | 2.4 kB
00:00
rpmfusion-free-updates                                   | 2.7 kB
00:00
rpmfusion-nonfree-updates                                | 2.7 kB
00:00
rpmfusion-free                                           |  951 B
00:00
updates-newkey                                           | 2.3 kB
00:00
updates                                                  | 2.6 kB
00:00
rpmfusion-nonfree                                        |  951 B
00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.27.12-78.2.8.fc9 set to be installed
---> Package kernel-devel.i686 0:2.6.27.12-78.2.8.fc9 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch     Version                     Repository
Size
================================================================================
Installing:
 kernel           i686     2.6.27.12-78.2.8.fc9        updates-newkey
19 M
 kernel-devel     i686     2.6.27.12-78.2.8.fc9        updates-newkey
5.5 M

Transaction Summary
================================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total size: 24 M
Is this ok [y/N]: y
Downloading Packages:
============================== Entering rpm code
===============================
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : kernel
1/2
initrdfile is /boot/initrd-2.6.27.12-78.2.8.fc9.i686.img
making it the default based on config
running depmod for 2.6.27.12-78.2.8.fc9.i686
creating initrd /boot/initrd-2.6.27.12-78.2.8.fc9.i686.img using
2.6.27.12-78.2.8.fc9.i686
found /boot/initrd-2.6.27.12-78.2.8.fc9.i686.img and using it with grubby
adding 2.6.27.12-78.2.8.fc9.i686 to /boot/grub/grub.conf
grubby fatal error: unable to find a suitable template
/etc/lilo.conf does not exist, not running grubby
  Installing     : kernel-devel
2/2
initrdfile is /boot/initrd-2.6.27.12-78.2.8.fc9.i686.img
=============================== Leaving rpm code
===============================

Installed:
  kernel.i686 0:2.6.27.12-78.2.8.fc9  kernel-devel.i686
0:2.6.27.12-78.2.8.fc9

Complete!


>
>> --
>> fedora-list mailing list
>> fedora-list at redhat.com
>> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
>> Guidelines:
>> http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/users/attachments/20090131/912b3572/attachment-0001.html 


More information about the users mailing list