Conflict with nVidia package upgrade

Doctor Who whodoctor at gmail.com
Thu Jun 18 18:36:42 UTC 2009


On Thu, Jun 18, 2009 at 12:09 PM, Doctor Who<whodoctor at gmail.com> wrote:
> Hi all-
>
> I'm getting the following error message when trying to do an update via yumex:
>
> Transaction Check Error:   file
> /lib/modules/2.6.29.4-167.fc11.i586/extra/nvidia/nvidia.ko from
> install of kmod-nvidia-2.6.29.4-167.fc11.i586-185.18.14-1.fc11.i586
> conflicts with file from package
> kmod-nvidia-2.6.29.4-167.fc11.i586-180.51-1.fc11.8.i586
>
> This is a Fedora 11 install with kernel 2.6.29.4-167.fc11.i686.PAE.
>
> 'yum list updates' filtered on nvidia packages shows:
>
> kmod-nvidia.i586                 185.18.14-1.fc11      rpmfusion-nonfree-updates
> kmod-nvidia-2.6.29.4-167.fc11.i586.i586
> xorg-x11-drv-nvidia.i586         185.18.14-2.fc11      rpmfusion-nonfree-updates
> xorg-x11-drv-nvidia-libs.i586    185.18.14-2.fc11      rpmfusion-nonfree-updates
>
> And I currently have installed:
>
> xorg-x11-drv-nvidia-180.51-1.fc11.i586
> kmod-nvidia-2.6.29.4-167.fc11.i586-180.51-1.fc11.8.i586
> xorg-x11-drv-nvidia-libs-180.51-1.fc11.i586
> kmod-nvidia-180.51-1.fc11.8.i586
> kmod-nvidia-2.6.27.21-170.2.56.fc10.i686-180.29-1.fc10.2.i686
> kmod-nvidia-2.6.27.24-170.2.68.fc10.i686-180.51-1.fc10.5.i686
> kmod-nvidia-2.6.27.19-170.2.35.fc10.i686-180.29-1.fc10.1.i686
>
> Not sure how there ended up being some many kmod-nvidia packages installed. :-(
>
> Anyway, how do i fix this so I can update to the most recent package?
>
> Thanks.
>

rpm -e yum-fedorakmod fixed it for me.




More information about the users mailing list