Problem when upgrading from F12 to F13

Frode fropeter at online.no
Wed Aug 25 15:10:45 UTC 2010


Jim skrev:
>   On 08/20/2010 03:11 PM, Michael Schwendt wrote:
>> On Fri, 20 Aug 2010 20:38:29 +0200, Jon wrote:
>>
>>> OK, I have done "yum upgrade" but after down load of all packages I get
>>> transacton error:
>>>
>>>     file /lib64/libdb-4.7.so from install of
>>> compat-db47-4.7.25-15.fc13.x86_64 conflicts with file from package
>>> db4-4.7.25-13.fc12.x86_64
>> There's a much newer db4 in Fedora 13 Updates, which should replace your
>> old one from F12:
>>
>> db4.i686                          4.8.30-1.fc13                         @updates
>> db4.x86_64                        4.8.30-1.fc13                         @updates
>>
>>>     file /usr/lib64/nautilus-sendto/plugins/libnstbluetooth.so from
>>> install of gnome-bluetooth-2.30.0-1.fc13.x86_64 conflicts with file from
>>> package nautilus-sendto-2.28.2-2.fc12.x86_64
>> What do you get for "yum list nautilus-sendto"?
>> There's a newer on in Fedora 13 Updates:
>>
>> nautilus-sendto.x86_64                   2.28.4-3.fc13                   updates
>>
>>> And I am not sure what I should do now. Any comments?
>> Verify your repository configuration and run some yum (or repoquery)
>> queries to show which package versions are available.
> 
> Here is the sequence you do the upgrade.
> 
> 
> 1.  Install the two Fedora-release-fc13 rpm's
> 
> 2.  do "yum clean all"
> 
> 3.  do  "yum upgrade"
> 
> 4.  Reboot
> 
> 5.  and "yum remove kernel-fc12"
> 
> 

Just curious: If I understand correctly, you don't use preupgrade. What 
are the pros/cons of the two methods?

I have previously only used fresh installs, but maybe upgrading could be 
worth a try afterall?

Regards, Frode


More information about the users mailing list