err:wineconsole:WINECON_Fatal Couldn't find a decent font, aborting

Joshua C. joshuacov at googlemail.com
Mon Aug 30 22:55:39 UTC 2010


2010/8/30 James Mckenzie <jjmckenzie51 at earthlink.net>:
> "Joshua C." <joshuacov at googlemail.com> wrote:
>>
>>Actually I need to run a simple batch file. That's why I used a
>>kde-livecd-f14-x86_64 and installed wine-core.i686 wine-wow.i686,
>>wine-common and wine-fonts. All dpendencies were pull automatically.
>>Wine works fine but when trying to start "wineconsole cmd" I got the
>>error message.
>
> Interesting.  I don't get that error on my Mac.  However, I did run winetricks allfonts on it.  I think you stated you had done this as well?
>>
>>Therefore I decided to use an older version of wine and tried the
>>f13.x86_64 livecd and installed exactly the same 4 packages. You can
>>find the current versions in the repo.
>>
> Since I don't have a 64 bit system, but can do exactly what you just did, I'll give it a try, soon.  I have to get the FC13 'stuff' and see what happens.
>
>>I remember that I did the same thing about 2-3 months ago and then I
>>didn't get this error. That's why I posted here to see if someelse has
>>had this problem.
>>
> Was this on FC13 or FC12/13 (if you can remember.)
>
>>Actually winconsole cmd doesn't work for me and wine does. That's
>>strange.To test it just grab the lasted livecd and install the
>>aforementioned packages. Trying different fonts didn't help either.
>
> Interesting because on my Mac, I had to do the opposite.  Maybe things are different on Linux/FC13.  Will find out quickly.
>
> And my apologies for sounding like a snob, but the more information provided up front the faster we, as voluteers, can provide you with assistance.  Otherwise, we have to make assumptions and mine were incorrect.
>
> It is interesting that a batch file is throwing these types of errors though.
>
> James McKenzie
>
> --
> users mailing list
> users at lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
>

I found something very interesting. As I said eralier I tried the same
packages some months ago and everything worked fine. So I just tested
all the packgaes until i found the "working" one. To clarify before I
start: wine works fine but the "wineconsole cmd" throws the error
about the missing font.

This is what I did:

I tested this on the f13-kde_livecd.x86_64

1. Install wine-core.i686, wine-wow.i686, wine-fonts, wine-common.
2. start wineconsole cmd WITHOUT starting winecfg before it
3. the error occurrs.
4. The only "working" package is 1.2.0-0.6.rc6. After installing it
and going through the steps 1-3 wineconsole shows that it's "Building
font metrics". After it has finished I can upgrade to the latest
1.3.1-1 and it works just fine.

if I delete the .wine directory AFTER the installation of
1.2.0-0.6.rc6 then the error occurs again and I have to go back to the
rc6 in order to enumerate the fonts.

This makes me believe that this font-enumeration writes something to
the .wine directory that's being used by the later versions. after
installing and starting the rc6 all other versions work fine, until I
delete the wine directory.

The change log for the rc7 packages says:
* Sun Jul 11 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.7.rc7
- version upgrade
- make sure font packages include the license file in case they are
installed standalone

I assume that the latest patch somehow assumes that if the fonts have
already been installed (separately) then it doesn't need to enumerate
all of them. As a result of this it doesn't write the "necessary"
information in the wine directory which cause wineconsole to throw the
error message.

I hope someone can better figure out why all the later verions work
only after installing and starting rc6 before them. Maybe this can
help.


More information about the users mailing list