radeon driver heading in wrong direction :-(.

Kevin Kofler kevin.kofler at chello.at
Sat Feb 6 11:37:36 UTC 2010

Brian Mury wrote:
> I disagree. As I posted earlier in this thread, my 9200 (rv280) does
> *not* work with the current drivers. Booting with KMS I get 2D and 3D
> that are both so slow they are unusable for many tasks (even watching a
> low resolution video pins the CPU and drops more frames than it plays).
> Booting with UMS I get good speed, but random X crashes - and 3D will
> almost always completely freeze the computer. I end up having to reboot
> just so I can, say, run Google Earth for a couple minutes, then reboot
> again to continue with what I was doing before.

I have a "ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)" and I'm 
running F12 with KMS enabled, 2D works perfectly, 3D is sometimes a bit 
"stuttery" (i.e. it freezes on a frame for a small fraction of a second, not 
enough to be seen as an outright freeze, but enough to be seen as frame 
jumping), but otherwise it just works. It did have several issues (crashes, 
assertion failures) on F11, and there was one assertion failure in Extreme 
Tux Racer in the F12 release, but that got fixed in the updates. (But it's 
true F10 was best. The drivers got refactored to work with the latest X11 
driver technologies and there were some regressions in the process.)

Now if you're expecting a performance beast, perhaps you're expecting too 
much from a Radeon 9200? (FYI, even current Intel integrated chipsets 
(GM965) perform better.)

        Kevin Kofler

More information about the users mailing list