Problem loading linux drivers for audio on motherboard

Stephen Gallagher sgallagh at redhat.com
Thu Jul 8 17:46:31 UTC 2010


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 07/08/2010 01:15 PM, Alan Nicoll wrote:
> I have determined my sound problem (no S/PDIF output) is due to not
> having the right drivers loaded.  The install.sh file that comes with
> the motherboard will not run; this code fails:
> 
> #Check if user have installed the kernel source
> echo "Second, please make sure you have installed the kernel source."
> if [ -L /lib/modules/$KERNEL_VER/source -a -L
> /lib/modules/$KERNEL_VER/build ]
>   then echo "It's OK."
> else echo "You haven't installed the kernel source." && exit 1
> fi
> 
> This fails because the links to 'source' and 'build' in
> /lib/modules/2.6.33.3-85.fc13.x86_64 are broken:
> 
>      This link cannot be used, because its target
> "../../../usr/src/kernels/2.6.33.3-85.fc13.x86_64" doesn't exist.
> 
> So now I'm a little lost as to what I need to do next.  My searches for
> info have returned some instructions for how to build a 'hello world'
> smple kernel module but I'm more interested in figuring out what
> module(s) are missing and how to install them.
> 
> Nick
> 

yum install kernel-devel

Then try again

- -- 
Stephen Gallagher
RHCE 804006346421761

Delivering value year after year.
Red Hat ranks #1 in value among software vendors.
http://www.redhat.com/promo/vendor/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.14 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org/

iEYEARECAAYFAkw2DvcACgkQeiVVYja6o6MK9wCeKS/f9k/BIAITcHxr+eGzG1r4
ZDYAoJKxWV4FIDVk6q9OIu7Nun30EDCx
=0EPY
-----END PGP SIGNATURE-----


More information about the users mailing list