how to uninstall preload?

Parshwa Murdia b330bkn at gmail.com
Tue Jul 20 12:10:28 UTC 2010


> ---------- Forwarded message ----------
> From: Adalbert Prokop <adalbert.prokop at gmx.de>
> To: Community support for Fedora users <users at lists.fedoraproject.org>
> Date: Tue, 20 Jul 2010 10:19:57 +0200
> Subject: Re: how to uninstall preload?

> The most convienient way would be
> su -c 'yum -y remove preload'
>
> A simple
>
> su -c "rpm -e preload"
>
> will also work.


Okay, but as I installed it with, yum, so I am guessing (but I don't
know if it is always true), I should use the first command you give,
that is,

su -c 'yum -y remove preload'


> ---------- Forwarded message ----------
> From: Suvayu Ali <fatkasuvayu+linux at gmail.com>
> To: users at lists.fedoraproject.org
> Date: Tue, 20 Jul 2010 02:24:25 -0700
> Subject: Re: how to uninstall preload?
> On Tuesday 20 July 2010 01:19 AM, Adalbert Prokop wrote:
>>
>> A simple
>>
>> su -c "rpm -e preload"
>>
>> will also work.
>
> However that is not recommended, at least that is what I know. This leaves yum in a state where it is unaware of the removed rpm. It is always recommended to use yum over rpm directly. :)



Oh, that's conceptual.



> ---------- Forwarded message ----------
> From: Timothy Murphy <gayleard at eircom.net>
> To: users at lists.fedoraproject.org
> Date: Tue, 20 Jul 2010 11:49:30 +0100
> Subject: Re: how to uninstall preload?
> Adalbert Prokop wrote:
>
>>> If the preload has been installed with the command:
>>>
>>> [fedorax at localhost ~]$ su -c 'yum -y install preload'
>>>
>>> and now if it is causing problems, how could it be uninstalled??
>>
>> The most convienient way would be
>> su -c 'yum -y remove preload'
>
> I would imagine the "-y" would be rather dangerous,
> as "yum remove" often tries to remove many packages
> required by other applications.

ok, so the command should be:

su -c 'yum remove preload'

and if while uninstallation it prompts for yes or know, we should
select yes, checking if the particular package may or may not be the
dependency for any other installed software??


More information about the users mailing list