FC13 PS2 Mouse/Keyboard stops working after a while

JD jd1008 at gmail.com
Wed Apr 6 23:01:08 UTC 2011

On 04/06/2011 03:21 PM, John Mellor wrote:
> On Wed, 2011-04-06 at 10:31 -0400, Lamar Owen wrote:
>> On Tuesday, April 05, 2011 07:20:40 PM compdoc wrote:
>>> So what you're saying is, while the M-Audio 1010 is working the ps/2 stuff
>>> fails, and when the M-Audio 1010 has stopped working due to
>>> suspend/hibernate the PS/2 stuff works fine. Coincidence?
>>> I find it odd that anything would interfere with a ps/2 keyboard, since it's
>>> on such a low and well known IRQ. Keyboard is 1 and mouse is 12.
>> I've seen issues with the M-Audio Delta 1010 and other Envy24-based boards with IRQ steering; I have a laptop with a dock that has a PCI slot in it, and have run a Delta 1010LT (same Envy24/ICE1712 chip; and it's the older 'still works with Linux/ALSA' version) in it.
>> If I loaded the nvidia kmod, the nvidia GPU grabs an IRQ; just so happens the PCI slot in the dock and the GPU share the same physical INT line, and either the nvidia or the Envy24's driver apparently doesn't handle IRQ sharing very well.  With the nvidia kmod loaded, I get frequent ALSA xruns, which glitch the audio.  Running the alternative nvidia drivers found in Fedora just causes performance to drop substantially; I then get JACK xruns, and still have glitches.... This is both with and without the preemption-RT patched kernel.  But it was an older Fedora; haven't tried in a while, since I installed the Delta 1010LT somewhere else and began using a different audio interface on the laptop.
>> To the OP: try putting the Delta 1010 in a different physical PCI slot, or use a USB keyboard (just make sure, using 'cat /proc/interrupts' that the ice1712 entry has its own IRQ and doesn't share with anything else).
> Interesting.  I have the opposite problem on my abit motherboard.  The
> PS2 mouse happens to work and my preferred USB mouse just locks up about
> 5 times per day.
> Is this a known problem with a simple fix?
I wonder if this is a "missed interrupts" problem.
Is the mouse's IRQ shared with some other device?

More information about the users mailing list