Package-cleanup --problems

Michael Schwendt mschwendt at
Mon Dec 12 18:27:03 UTC 2011

On Mon, 12 Dec 2011 12:54:06 -0200, LGDF (Lucélio) wrote:

> One more question please:
> Where in the messages I sent, you got shure that they are orphaned and
> from old installs?

You can run "yum list extras",

|       yum list extras [glob_exp1] [...]
|              List the packages installed on the system that are not available
|              in any yum repository listed in the config file.

and query for package names such as "yum list kudzu" to find out whether
such a package is still offered in the repositories:

# yum list kudzu rhpl
Loaded plugins: langpacks, presto, refresh-packagekit
Error: No matching Packages to list

> >> Package rhpl-0.221-2.x86_64 requires
> >> Package rhpl-0.221-2.x86_64 requires python(abi) = ('0', '2.6', None)
> >> Package kudzu-1.2.86-2.x86_64 requires python(abi) = ('0', '2.6', None)

More information about the users mailing list