f14 :: partitionable raid1 :: there is no md_d0pX

Adrian Sevcenco Adrian.Sevcenco at cern.ch
Wed Nov 9 21:17:40 UTC 2011


Hi,
I have 2 disks for doing raid1 and the layout is 2 primary partitions.
I tried to do a partionable raid1 as in
http://wiki.centos.org/HowTos/Install_On_Partitionable_RAID1 thinking
that linux is linux and the underlying mechanics is the same.
i did this :
mdadm --create --level=1 --raid-devices=2 /dev/md_d0 /dev/sdb missing
mdadm --add /dev/md_d0 /dev/sdc

the sync is doing ok :
root at adrian: ~ # cat /proc/mdstat
Personalities : [raid1]
md_d0 : active raid1 sdc[2] sdb[0]
      976760367 blocks super 1.2 [2/1] [U_]
      [====>................]  recovery = 22.2% (217118464/976760367)
finish=134.8min speed=93842K/sec

root at adrian: ~ # mdadm --detail /dev/md_d0
/dev/md_d0:
        Version : 1.2
  Creation Time : Wed Nov  9 22:33:42 2011
     Raid Level : raid1
     Array Size : 976760367 (931.51 GiB 1000.20 GB)
  Used Dev Size : 976760367 (931.51 GiB 1000.20 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Wed Nov  9 23:06:26 2011
          State : clean, degraded, recovering
 Active Devices : 1
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 1

 Rebuild Status : 22% complete

           Name : adrian.home:d0  (local to host adrian.home)
           UUID : 020aaa6d:5e7cc4ba:38d839fb:4ce0b368
         Events : 11

    Number   Major   Minor   RaidDevice State
       0       8       16        0      active sync   /dev/sdb
       2       8       32        1      spare rebuilding   /dev/sdc

the problems is the following :
root at adrian: ~ # mdadm --examine --scan
ARRAY /dev/md/d0 metadata=1.2 UUID=020aaa6d:5e7cc4ba:38d839fb:4ce0b368
name=adrian.home:d0

where instead of /dev/md_d0 it shows /dev/md/d0.
as in the mentioned howto i modified the mdadm.conf but i still dont
have the md devices! i would have expected (as in centos5)
to have md_d0p1 and md_d0p2
Did anyone used partitonable raid1 in fedora? what were your
experiences? have anyone an idea about my problem?

Thanks,
Adrian








-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3110 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.fedoraproject.org/pipermail/users/attachments/20111109/612d69ee/attachment.bin 


More information about the users mailing list