Fed 16 + Broadcom wlan 4312 + kernel-3.2.1-3

T.C. Hollingsworth tchollingsworth at gmail.com
Tue Jan 24 18:23:50 UTC 2012

On Tue, Jan 24, 2012 at 10:05 AM, Alexander Volovics
<a.volovic at upcmail.nl> wrote:
> I have a Broadcom wlan 4312 [14e4:4315] in my laptop.
> After the latest kernel update to kernel-3.2.1-13 I decided to install
> the necessary firmware heeding the following dmesg output:
> [   82.515047] b43-phy0 ERROR: Firmware file "b43/ucode15.fw" not found
> [   82.515054] b43-phy0 ERROR: Firmware file "b43-open/ucode15.fw" not found
> [   82.515060] b43-phy0 ERROR: You must go to
> http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download
> the correct firmware for this driver version. Please carefully read all
> instructions on this website.
> The website suggests downloading broadcom-wl-5.100.138.tar.bz2 if using the
> b43 driver from the 3.2 kernel.
> I did that but then this happens:
> b43-fwcutter -w /lib/firmware wl_apsta.o
> Sorry, the input file is either wrong or not supported by b43-fwcutter.
> This file has an unknown MD5sum e1b05e268bcdbfef3560c28fc161f30
> b43-fwcutter in Fed 16 is version 0.14 and indeed the FW15 file supported by
> b43-fwcutter version 0.14 has a different md5sum.
> The wireless.kernel.org site also advices using b43-fwcutter version 0.15
> but this version does not seem to be available for fed 16.
> Can this be the problem?

It is the problem.  That firmware needs b43-fwcutter-015; older
versions won't work with it.

I filed a bug [1] asking for b43-fwcutter to be updated.  In the
meantime, I built an updated version because I'll probably need it for
one of my machines when it gets updated later:


[1] https://bugzilla.redhat.com/show_bug.cgi?id=784390

More information about the users mailing list