how to remove uninstalled duplicates

Ranjan Maitra maitra.mbox.ignored at inbox.com
Wed Dec 18 15:33:26 UTC 2013


Hi,

Following up on this post, it appears that the F20 duplicates have been
downloaded but not installed. I tried removing the duplicates using 


https://franx47.wordpress.com/2013/02/01/removing-duplicate-rpm-packages/

but the error message is that the duplicates are downloaded but not
installed. 

Does anyone know how to remove, or alternatively install, these
duplicates?

Many thanks,
Ranjan


On Tue, 17 Dec 2013 22:15:15 -0600 Ranjan Maitra
<maitra.mbox.ignored at inbox.com> wrote:

> Hi,
> 
> I did an upgrade from F19 to F20 on three machines (2 laptops and 1
> desktop). For one laptop and the desktop, things went smoothly -- no
> complaints: I used yum/fedora-upgrade. 
> 
> For the other, while upgrading, the X crashed and there
> were comments about journald, bluetooth etc (not sure if this has
> anything to do with anything or the upgrade) and so I am left with a
> bunch of F19 and F20 packages. I am able to run as if nothing has
> happened (though unclear whether I am running a F19 or a F20 system) but
> this is really a system which can not be updated. 
> 
> I tried doing the following, for want of knowing what to do:
> 
> %sudo yum --releasever=20 distro-sync
> 
> and I get the following:
> 
> Loaded plugins: fastestmirror, langpacks, remove-with-leaves
> Loading mirror speeds from cached hostfile
>  * fedora: kdeforge.unl.edu
>  * rpmfusion-free-rawhide: mirrors.tummy.com
>  * rpmfusion-nonfree: rpmfusion.famillecollet.com
>  * rpmfusion-nonfree-updates: rpmfusion.famillecollet.com
>  * updates: mirror.unl.edu
> Resolving Dependencies
> --> Running transaction check
> ---> Package SDL.x86_64 0:1.2.15-11.fc20 will be updated
> ---> Package SDL.x86_64 0:1.2.15-12.fc19 will be updated
> ---> Package SDL.x86_64 0:1.2.15-12.fc20 will be an update
> ---> Package autocorr-en.noarch 1:4.1.3.2-10.fc20 will be a downgrade
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> ---> Package bluez.x86_64 0:5.12-1.fc20 will be obsoleting
> ---> Package createrepo.noarch 0:0.9.9-22.fc20 will be a downgrade
> ---> Package createrepo.noarch 0:0.10-1.fc19 will be erased
> ---> Package dbus.x86_64 1:1.6.12-1.fc20 will be a downgrade
> ---> Package dbus.x86_64 1:1.6.12-2.fc19 will be erased
> ---> Package dbus-libs.x86_64 1:1.6.12-1.fc20 will be a downgrade
> ---> Package dbus-libs.x86_64 1:1.6.12-2.fc19 will be erased
> ---> Package dbus-x11.x86_64 1:1.6.12-1.fc20 will be a downgrade
> ---> Package dbus-x11.x86_64 1:1.6.12-2.fc19 will be erased
> ---> Package faad2-libs.x86_64 1:2.7-2.fc17 will be a downgrade
> ---> Package faad2-libs.x86_64 1:2.7-4.fc19 will be erased
> ---> Package fedora-upgrade.noarch 0:20.2-1.fc19 will be updated
> ---> Package fedora-upgrade.noarch 0:20.2-1.fc20 will be an update
> ---> Package firefox.x86_64 0:26.0-2.fc19 will be updated
> ---> Package firefox.x86_64 0:26.0-3.fc20 will be an update
> ---> Package gnutls.x86_64 0:3.1.16-1.fc20 will be updated
> ---> Package gnutls.x86_64 0:3.1.17-2.fc19 will be updated
> ---> Package gnutls.x86_64 0:3.1.17-3.fc20 will be an update
> ---> Package google-crosextra-caladea-fonts.noarch
> 0:1.002-0.1.20130214.fc20 will be a downgrade
> ---> Package google-crosextra-caladea-fonts.noarch
> 0:1.002-0.2.20130214.fc19 will be erased
> ---> Package libreoffice-opensymbol-fonts.noarch 1:4.1.3.2-10.fc20 will
> be a downgrade
> ---> Package libreoffice-opensymbol-fonts.noarch 1:4.1.3.2-12.fc19 will
> be erased
> ---> Package libreoffice-ure.x86_64 1:4.1.3.2-10.fc20 will be a
> downgrade
> ---> Package libreoffice-ure.x86_64 1:4.1.3.2-12.fc19 will be erased
> ---> Package libreport-filesystem.x86_64 0:2.1.9-1.fc20 will be updated
> ---> Package libreport-filesystem.x86_64 0:2.1.10-1.fc19 will be updated
> ---> Package libreport-filesystem.x86_64 0:2.1.10-1.fc20 will be an
> update
> ---> Package mesa-libGLU.x86_64 0:9.0.0-3.fc20 will be a downgrade
> ---> Package mesa-libGLU.x86_64 0:9.0.0-4.fc19 will be erased
> ---> Package obex-data-server.x86_64 1:0.4.6-5.fc19 will be obsoleted
> ---> Package opus.x86_64 0:1.0.3-2.fc20 will be updated
> ---> Package opus.x86_64 0:1.1-1.fc19 will be updated
> ---> Package opus.x86_64 0:1.1-1.fc20 will be an update
> ---> Package python-urlgrabber.noarch 0:3.9.1-32.fc20 will be a
> downgrade
> ---> Package python-urlgrabber.noarch 0:3.10-0.fc19 will be erased
> ---> Package rpmconf.noarch 0:0.3.4-1.fc19 will be updated
> ---> Package rpmconf.noarch 0:0.3.5-1.fc20 will be an update
> --> Processing Dependency: rpmconf-base for package:
> rpmconf-0.3.5-1.fc20.noarch
> ---> Package satyr.x86_64 0:0.11-1.fc20 will be updated
> ---> Package satyr.x86_64 0:0.12-1.fc19 will be updated
> ---> Package satyr.x86_64 0:0.12-1.fc20 will be an update
> ---> Package ssmtp.x86_64 0:2.64-9.fc20 will be a downgrade
> ---> Package ssmtp.x86_64 0:2.64-10.fc19 will be erased
> ---> Package usb_modeswitch-data.noarch 0:20130807-1.fc20 will be a
> downgrade
> ---> Package usb_modeswitch-data.noarch 0:20131113-1.fc19 will be erased
> ---> Package vim-common.x86_64 2:7.4.027-2.fc19 will be updated
> ---> Package vim-common.x86_64 2:7.4.027-2.fc20 will be an update
> ---> Package vim-enhanced.x86_64 2:7.4.027-2.fc19 will be updated
> ---> Package vim-enhanced.x86_64 2:7.4.027-2.fc20 will be an update
> ---> Package vim-filesystem.x86_64 2:7.4.027-2.fc19 will be updated
> ---> Package vim-filesystem.x86_64 2:7.4.027-2.fc20 will be an update
> ---> Package xorg-x11-drv-modesetting.x86_64 0:0.8.0-2.fc20 will be a
> downgrade
> ---> Package xorg-x11-drv-modesetting.x86_64 0:0.8.0-3.fc19 will be
> erased
> ---> Package xulrunner.x86_64 0:26.0-1.fc19 will be updated
> ---> Package xulrunner.x86_64 0:26.0-2.fc20 will be an update
> ---> Package youtube-dl.noarch 0:2013.11.25.3-1.fc20 will be a downgrade
> ---> Package youtube-dl.noarch 0:2013.12.04-1.fc19 will be erased
> --> Running transaction check
> ---> Package rpmconf-base.noarch 0:0.3.5-1.fc20 will be installed
> --> Finished Dependency Resolution
> --> Running transaction check
> ---> Package autocorr-en.noarch 1:4.1.3.2-10.fc20 will be a downgrade
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> ---> Package autocorr-en.noarch 1:4.1.3.2-12.fc19 will be erased
> --> Finished Dependency Resolution
> 
> Dependencies Resolved
> 
> ================================================================================
>  Package                      Arch   Version
> Repository   Size
> ================================================================================
> Installing: bluez                        x86_64
> 5.12-1.fc20              fedora      905 k replacing
> obex-data-server.x86_64 1:0.4.6-5.fc19 Updating:
>  SDL                          x86_64 1.2.15-12.fc20
> updates     207 k fedora-upgrade               noarch
> 20.2-1.fc20              fedora       29 k firefox
> x86_64 26.0-3.fc20              updates      27 M
> gnutls                       x86_64 3.1.17-3.fc20
> updates     607 k libreport-filesystem         x86_64
> 2.1.10-1.fc20            updates      32 k opus
> x86_64 1.1-1.fc20               updates     655 k
> rpmconf                      noarch 0.3.5-1.fc20
> fedora       21 k satyr                        x86_64
> 0.12-1.fc20              updates     483 k vim-common
> x86_64 2:7.4.027-2.fc20         fedora      5.9 M
> vim-enhanced                 x86_64 2:7.4.027-2.fc20
> fedora      1.0 M vim-filesystem               x86_64
> 2:7.4.027-2.fc20         fedora      9.3 k xulrunner
> x86_64 26.0-2.fc20              updates      23 M Removing:
> autocorr-en                  noarch 1:4.1.3.2-12.fc19
> @updates/19 450 k Reinstalling: dbus                         x86_64
> 1:1.6.12-1.fc20          fedora      303 k dbus-libs
> x86_64 1:1.6.12-1.fc20          fedora      147 k
> dbus-x11                     x86_64 1:1.6.12-1.fc20
> fedora       44 k faad2-libs                   x86_64
> 1:2.7-2.fc17             rpmfusion-free-rawhide 147 k
> mesa-libGLU                  x86_64 9.0.0-3.fc20
> fedora      196 k python-urlgrabber            noarch
> 3.9.1-32.fc20            fedora      106 k ssmtp
> x86_64 2.64-9.fc20              fedora       50 k
> usb_modeswitch-data          noarch 20130807-1.fc20
> fedora       70 k Downgrading: createrepo                   noarch
> 0.9.9-22.fc20            fedora       91 k
> google-crosextra-caladea-fonts noarch 1.002-0.1.20130214.fc20
> fedora       91 k libreoffice-opensymbol-fonts noarch
> 1:4.1.3.2-10.fc20        updates     194 k libreoffice-ure
> x86_64 1:4.1.3.2-10.fc20        updates     2.6 M
> xorg-x11-drv-modesetting     x86_64 0.8.0-2.fc20
> fedora       26 k youtube-dl                   noarch
> 2013.11.25.3-1.fc20      updates     274 k Installing for dependencies:
> rpmconf-base                 noarch 0.3.5-1.fc20
> fedora      5.1 k
> 
> Transaction Summary
> ================================================================================
> Install     1 Package  (+1 Dependent package)
> Upgrade    12 Packages
> Remove      1 Package
> Reinstall   8 Packages
> Downgrade   6 Packages
> 
> Total size: 64 M
> Is this ok [y/d/N]: y
> Downloading packages:
> Running transaction check
> Running transaction test
> 
> 
> Transaction check error:
>   package dbus-libs-1:1.6.12-1.fc20.x86_64 is already installed
>   package dbus-1:1.6.12-1.fc20.x86_64 is already installed
>   package dbus-x11-1:1.6.12-1.fc20.x86_64 is already installed
>   package python-urlgrabber-3.9.1-32.fc20.noarch is already installed
>   package faad2-libs-1:2.7-2.fc17.x86_64 is already installed
>   package usb_modeswitch-data-20130807-1.fc20.noarch is already
> installed package ssmtp-2.64-9.fc20.x86_64 is already installed
>   package mesa-libGLU-9.0.0-3.fc20.x86_64 is already installed
> 
> Error Summary
> -------------
> 
> % 
> 
> I can not get out of this. No matter what i do, here is where I end. 
> 
> Any suggestions? I don't know that yum upgrade is the issue here (and
> I have always been successful with it). Rather, I think something when
> the upgrade was happening impacted something that is different on this
> laptop and took out the X. 
> 
> I don't really want to reinstall if I can help it. Of course, I may
> have not much option.
> 
> Any suggestion to help resolve this is greatly appreciated.
> 
> Many thanks and best wishes,
> Ranjan
> 
> PS: As an aside, yum distro-sync wants to downgrade to F19, but I get a
> bunch of duplicates warnings.
> 
> Many thanks,
> Ranjan
> 
> 
> -- 
> Important Notice: This mailbox is ignored: e-mails are set to be
> deleted on receipt. Please respond to the mailing list if appropriate.
> For those needing to send personal or professional e-mail, please use
> appropriate addresses.
> 
> ____________________________________________________________
> FREE ONLINE PHOTOSHARING - Share your photos online with your friends and family!
> Visit http://www.inbox.com/photosharing to find out more!
> 
> 
> -- 
> users mailing list
> users at lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Fedora Code of Conduct: http://fedoraproject.org/code-of-conduct
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> Have a question? Ask away: http://ask.fedoraproject.org


-- 
Important Notice: This mailbox is ignored: e-mails are set to be
deleted on receipt. Please respond to the mailing list if appropriate.
For those needing to send personal or professional e-mail, please use
appropriate addresses.

____________________________________________________________
FREE 3D MARINE AQUARIUM SCREENSAVER - Watch dolphins, sharks & orcas on your desktop!
Check it out at http://www.inbox.com/marineaquarium




More information about the users mailing list