issues with upgrade from f19 -> f20

Garry T. Williams gtwilliams at gmail.com
Sun Dec 22 04:56:35 UTC 2013


On 12-17-13 22:15:15 Ranjan Maitra wrote:
> %sudo yum --releasever=20 distro-sync
>
> and I get the following:

[snip]

> Transaction check error:
>   package dbus-libs-1:1.6.12-1.fc20.x86_64 is already installed
>   package dbus-1:1.6.12-1.fc20.x86_64 is already installed
>   package dbus-x11-1:1.6.12-1.fc20.x86_64 is already installed
>   package python-urlgrabber-3.9.1-32.fc20.noarch is already installed
>   package faad2-libs-1:2.7-2.fc17.x86_64 is already installed
>   package usb_modeswitch-data-20130807-1.fc20.noarch is already
> installed package ssmtp-2.64-9.fc20.x86_64 is already installed
>   package mesa-libGLU-9.0.0-3.fc20.x86_64 is already installed
>
> I can not get out of this. No matter what i do, here is where I end.
>
> Any suggestions?

I did the yum upgrade on my laptop and ran into a similar problem.
I ended up with a half-upgraded system when the yum command hung
updating systemd.

The fix is to manually erase the fc19 packages noted in this:

    package-cleanup --dupes

And then do

    yum distro-sync

On my desktop system I tried fedup for the first time and all went
flawlessly.

-- 
Garry T. Williams



More information about the users mailing list