fedup leaves half done 18 > 19

John Aldrich jmaldrich at yahoo.com
Thu Dec 26 20:25:12 UTC 2013


Quoting Sean Darcy <seandarcy2 at gmail.com>:

> I'm trying to upgrade FC18 to FC19. Ran fedup --network 19.
>
> got this "non-fatal" error:
>
> 120.813] (II) fedup.yum:build_update_transaction()
> systemd-sysv-201-2.fc18.9.x86_64 requires systemd = 201-2.fc18.9
> 120.815] (II) fedup.yum:build_update_transaction()
> libgudev1-201-2.fc18.9.x86_64 requires systemd = 201-2.fc18.9
>
> But seemed to work fine:
>
> 615.833] (II) fedup:<module>() /usr/bin/fedup exiting cleanly at Wed
> Dec 25 17:40:00 2013
>
> Rebooted. Saw the start of the upgrade transaction. All seemed fine.
> Saw first packages being installed.
>
> Came back after a couple of hours. Screen blank.
>
> Rebooted. No FC19. Booted into FC18.
>
> Is there a log of what happened in the upgrade itself?
>
> Now I have 1400 of fc19 packages installed.
>
> rpm -qa | grep fc19 | wc -l
> 1406
>
> but not the fc19 kernel.
>
> All the fc18 packages are still there:
>
> rpm -qa | grep fc18 | wc -l
> 1782
>
> Tried to run fedup again, but no luck:
>
> [   190.819] (II) fedup.yum:build_update_transaction() buildTransaction
> returned 1
> [   190.820] (II) fedup.yum:build_update_transaction()     Depsolving
> loop limit reached.
> [   190.821] (II) fedup.yum:build_update_transaction()
> systemd-python-201-2.fc18.9.x86_64 requires systemd = 201-2.fc18.9
> [   190.822] (II) fedup.yum:build_update_transaction()
> avahi-ui-gtk3 conflicts with avahi-0.6.31-6.fc18.x86_64
> [   190.822] (II) fedup.yum:build_update_transaction()
> libsss_sudo-1.9.6-1.fc18.x86_64 requires sssd = 1.9.6-1.fc18
> [   190.822] (II) fedup.yum:build_update_transaction()
> systemd-sysv-201-2.fc18.9.x86_64 requires systemd = 201-2.fc18.9
> [   190.822] (II) fedup.yum:build_update_transaction()
> libgudev1-201-2.fc18.9.x86_64 requires systemd = 201-2.fc18.9
> [   190.822] (II) fedup.yum:build_update_transaction()
> avahi-autoipd conflicts with avahi-0.6.31-6.fc18.x86_64
> [   190.823] (II) fedup.yum:build_update_transaction()
> PackageKit-0.8.9-1.fc18.x86_64 requires preupgrade
> [   190.823] (II) fedup.yum:build_update_transaction()     avahi-libs
> conflicts with avahi-0.6.31-6.fc18.x86_64
>
> and then dies with a python error:
>
> [   240.965] (DD) fedup.yum:yum_plugin_for_exc() checking traceback
> files: ['/usr/bin/fedup-cli', '/usr/bin/fedup-cli']
> [   240.965] (DD) fedup.yum:yum_plugin_for_exc() plugin path is
> ['/usr/share/yum-plugins', '/usr/lib/yum-plugins']
> [   240.965] (II) fedup:<module>() Exception:
> Traceback (most recent call last):
>   File "/usr/bin/fedup-cli", line 236, in <module>
>     main(args)
>   File "/usr/bin/fedup-cli", line 216, in main
>     for line in s.format_details():
> AttributeError: 'ProblemSummary' object has no attribute 'format_details'
> [   240.966] (II) fedup:<module>() /usr/bin/fedup-cli exiting with
> unhandled exception at Thu Dec 26 10:45:19 2013
>
> So I can't go forward with fedup. No clue what was the problem
> upgrading. (there _really_ should be an upgrade log!)
>
> Any help really appreciated.
>
> sean
>
> -- 
> users mailing list
> users at lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Fedora Code of Conduct: http://fedoraproject.org/code-of-conduct
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> Have a question? Ask away: http://ask.fedoraproject.org


I think you did what I did and rebooted in the middle of the upgrade.  
I'm in a similar pickle. I'm going to try FedUp one more time, but I'm  
thinking I'm going to have to do a fresh install to get F20. :(


More information about the users mailing list