[fedora-virt-maint] [libvirt] Fix libvirt-0.9.0 build for rawhide, Daniel

Daniel Veillard veillard at fedoraproject.org
Fri Apr 8 07:16:56 UTC 2011


commit 6c32e1aaeb4f9db5cace5c4c86fb5309f7cd4b49
Author: Daniel Veillard <veillard at redhat.com>
Date:   Fri Apr 8 15:16:29 2011 +0800

    Fix libvirt-0.9.0 build for rawhide, Daniel

 libvirt-0.9.0-libxl_log_dir.patch |   12 ++++++++++++
 libvirt.spec                      |   11 +++++++++--
 2 files changed, 21 insertions(+), 2 deletions(-)
---
diff --git a/libvirt-0.9.0-libxl_log_dir.patch b/libvirt-0.9.0-libxl_log_dir.patch
new file mode 100644
index 0000000..52b7124
--- /dev/null
+++ b/libvirt-0.9.0-libxl_log_dir.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 9b54679..099f21a 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1275,6 +1275,7 @@ endif
+ if WITH_LIBXL
+ 	$(MKDIR_P) "$(DESTDIR)$(localstatedir)/lib/libvirt/libxl"
+ 	$(MKDIR_P) "$(DESTDIR)$(localstatedir)/run/libvirt/libxl"
++	$(MKDIR_P) "$(DESTDIR)$(localstatedir)/log/libvirt/libxl"
+ endif
+ if WITH_UML
+ 	$(MKDIR_P) "$(DESTDIR)$(localstatedir)/lib/libvirt/uml"
diff --git a/libvirt.spec b/libvirt.spec
index a27832e..7cbab07 100644
--- a/libvirt.spec
+++ b/libvirt.spec
@@ -133,8 +133,6 @@
 # Fedora doesn't have new enough Xen for libxl until F16
 %if 0%{?fedora} < 16
 %define with_libxl 0
-%else
-%define with_libxl 1
 %endif
 
 # PolicyKit was introduced in Fedora 8 / RHEL-6 or newer
@@ -224,6 +222,9 @@ Group: Development/Libraries
 Source: http://libvirt.org/sources/libvirt-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 URL: http://libvirt.org/
+Patch1: libvirt-0.9.0-libxl_log_dir.patch
+# Required by above patch
+BuildRequires: autoconf automake libtool gettext-devel
 
 # All runtime requirements for the libvirt package (runtime requrements
 # for subpackages are listed later in those subpackages)
@@ -312,6 +313,10 @@ BuildRequires: python-devel
 
 %if %{with_xen}
 BuildRequires: xen-devel
+# temporary explicit requireent missing from xen-4.1.0
+%if %{with_libxl}
+BuildRequires: libuuid-devel
+%endif
 %endif
 BuildRequires: libxml2-devel
 BuildRequires: xhtml1-dtds
@@ -500,6 +505,7 @@ of recent versions of Linux (and other OSes).
 
 %prep
 %setup -q
+%patch1 -p1
 
 %build
 %if ! %{with_xen}
@@ -645,6 +651,7 @@ of recent versions of Linux (and other OSes).
 %define with_packager_version --with-packager-version="%{release}"
 
 
+autoreconf -if
 %configure %{?_without_xen} \
            %{?_without_qemu} \
            %{?_without_openvz} \


More information about the virt-maint mailing list