[fedora-virt] virsh Segfault after creation of guest [with virt-preview repo; F17 guest on F17 host]

Kashyap Chamarthy kashyapc at fedoraproject.org
Sat Jul 28 14:10:47 UTC 2012


I'm just trying to create a minimal(@core) Fedora 17 guest on F17 host, using Virt- preview.

So, once I create the minimal guest (using the attached script), the guest attempts to
reboot, and it's just hung there, I could see that on the serial console. I tried to do a
'virsh list', it's just hung there too, When I tried to look into logs, I see a virsh

=> Version Info: <=
I'm using the packages from 'virt-preview' repo
[root at moon ~]# uname -r ; arch ; rpm -q qemu-kvm libvirt
[root at moon ~]#
[root at moon qemu]# cat /etc/fedora-release
Fedora release 17 (Beefy Miracle)
[root at moon qemu]#


=> From /var/log/messages <=

Jul 28 18:26:08 moon libvirtd[18901]: 2012-07-28 12:56:08.066+0000: 18901: error :
virNetSocketReadWire:1006 : End of file while reading data: Input/output error
Jul 28 18:26:15 moon kernel: [296929.644578] virsh[20063]: segfault at 96 ip
00007f4d5100ff31 sp 00007fffd7978688 error 4 in libc-2.15.so[7f4d50f8a000+1ac000]
Jul 28 18:26:15 moon libvirtd[18901]: 2012-07-28 12:56:15.176+0000: 18901: error :
virNetSocketReadWire:1006 : End of file while reading data: Input/output error

Jul 28 18:53:09 moon libvirtd[21293]: 2012-07-28 13:23:09.037+0000: 21293: warning :
virDriverLoadModule:72 : Module /usr/lib64/libvirt/connection-d
river/libvirt_driver_libxl.so not accessible
Jul 28 18:53:09 moon libvirtd[21293]: 2012-07-28 13:23:09.656+0000: 21379: error :
qemuMonitorOpenUnix:308 : failed to connect to monitor socket: No such process
Jul 28 18:54:36 moon libvirtd[21293]: 2012-07-28 13:24:36.640+0000: 21293: error :
daemonStreamHandleAbort:622 : stream aborted at client request

To avoid this, I have to stop libvirtd service (here, it takes a little while to stop the
service. Then, again start the libvirtd service). Now, I can use virsh, and start the
guest and see the boot progress via serial console.

Just wondering if it's a known issue, before I file a bug.

If needed, I can provide further debugging info by enabling LIBVIRT_DEBUG=1 on the shell
when it hangs. Just let me know.

-------------- next part --------------

#Let's create a minimal kickstart file with serial console enabled
#NOTE for F16 serial console login w/o any line-breaks, disable plymouth service and reboot the vm -- $ ln -s /dev/null /etc/systemd/system/plymouth-start.service

cat << EOF > fed.ks
lang en_US.UTF-8
keyboard us
network --bootproto dhcp
rootpw testpwd
firewall --enabled --ssh
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --append="console=tty0 console=ttyS0,115200 rd_NO_PLYMOUTH serial text"
clearpart --all --initlabel


#Disk Image location

#Create the qcow2 disk image with preallocation and 'facllocate'(which pre-allocates all the blocks to a file) it for max. performance
echo "Creating qcow2 disk image.."
qemu-img create -f qcow2 -o preallocation=metadata $diskimage 20G
fallocate -l `ls -al $diskimage | awk '{print $5}'` $diskimage
echo `ls -lash $diskimage`

#Create the regular-guest
virt-install --connect=qemu:///system \
    --network=bridge:br0 \
    --initrd-inject=/root/nested-test/fed.ks \
    --extra-args="ks=file:/fed.ks console=tty0 console=ttyS0,115200 serial rd_NO_PLYMOUTH" \
    --name=regular-guest \
    --disk path=$diskimage,format=qcow2,cache=none \
    --ram 4096 \
    --vcpus=4 \
    --check-cpu \
    --accelerate \
    --os-type linux \
    --os-variant fedora17 \
    --cpuset auto \
    --hvm \
    --location=http://foo.bar.redhat.com/pub/fedora/linux/development/17/x86_64/os/ \

More information about the virt mailing list