Xfce 4.10

Panu Matilainen pmatilai at laiskiainen.org
Tue May 1 12:30:28 UTC 2012


On 05/01/2012 01:00 AM, Christoph Wickert wrote:
> Am Montag, den 30.04.2012, 21:25 +0200 schrieb Sebastian Krämer:
>> On 04/29/2012 12:27 PM, Miro Hrončok wrote:
>>> Hi, thanks for your repo.
>>>
>>> I got an error about libxfce4util (translated form Czech):
>>> ..
>>
>> Similar results here when trying to install xfburn:
>>
>>> Error: Package: xfburn-0.4.3-7.fc17.x86_64 (fedora)
>>>             Requires: libxfce4util.so.4()(64bit)
>>>             Available: libxfce4util-4.8.2-2.fc17.x86_64 (fedora)
>>>                 libxfce4util.so.4()(64bit)
>>>             Installed: libxfce4util-4.9.1-1.fc17.x86_64 (@fedora-xfce-4.10)
>>>                 Not found
>
> While all other issues are fixed this is the only remaining one. xfburn
> does not work with Xfce 4.10. Currently there is other solution but
> uninstalling it.

xfburn-0.4.3 needs a one-liner patch (see below) for a missing include 
to get it built on rawhide, I'd assume the same would allow it to build 
on f17 as well as they both appear to be on the same glib version.

Whether that's sufficient to make it *work* is a whole another question 
though...

	- Panu -

--- xfburn-0.4.3/xfburn/xfburn-settings.h.gobject       2012-05-01 
14:57:04.313229471 +0300
+++ xfburn-0.4.3/xfburn/xfburn-settings.h       2012-05-01 
14:58:15.498410269 +0300
@@ -24,6 +24,7 @@
  #endif /* !HAVE_CONFIG_H */

  #include <glib.h>
+#include <glib-object.h>

  G_BEGIN_DECLS



More information about the xfce mailing list